Over extrusion, pressure advance settings and jerk setting relation



  • Hi,

    In my quest to tune perfectly my printer i encounter a big problem, lowpoly shape were printing perfectly against hi-res and curvy model were over extruded, sometime 50 % more.
    I was close to remove my duetwifi as it was a really big mess.

    I found that the pressure advance setting give me lot of problem, more my value is more i get jerky movement and more there was blob / over extrusion on short move/complex path. For example with 0.08 in pressure advance i've to set my jerk to 100 to keep the same visual extrusion rate….. Otherwise i've to set down the extrusion rate to 50%....

    So now i've completely disable this option, and everything works correctly in all scenario.

    I hope this can help people to tune their printer.

    Best regards,
    Hugues,


  • administrators

    Which firmware version were you running? There have been various fixes to the pressure advance code, the most recent being at version 1.17c.



  • Hi,
    I use the last 1.18. And i also try several previous firmware version.
    It's a core xy printer and since i remove the pressure advance, there is nothing to compare.



  • Which slicer are you using? Are you using absolute or relative coordinates for extrusion? Can you upload a gcode file and share it here for troubleshooting?



  • @bot:

    Which slicer are you using? Are you using absolute or relative coordinates for extrusion? Can you upload a gcode file and share it here for troubleshooting?

    I've try sli3r and simplify 3d, i work in relative extrusion mode. I get same result on both slicer with my printer setup at 1000 in jerk and pressure was setup to 0.1 (i started from 0.05) when i find this relationship. It's happen on lot of files, 3d files made by me or downloaded from thingiverse with lot of mesh in a short distance with direction changing a lot.
    At the begining, i think it was a mechanical problem, i removed all belt and checked the smooth of motion but there was nothing to find. Next i downgraded to the first firmware ( i've one of the beta board) and i printed some hi-res mesh in really high speed with success when testing the board. Same result with the same files, overextruded print and jerky/paused motion.
    Go back to the last firmware this morning, and i decided to play with jerk, my setup is pretty high, maybe too ambitious… so i begining to go down and i noticed less overextrusion more i decrease the jerck value but to get something acceptable i was near 50 and my printer was close to move by itselft with all vibrations done. Weird result when i compare a print of a lowpoly model made at 100% with my setup and printed in hi speed without artifact.
    Chatting with a coworker about this problem, we listed all tests done and all options activated from slicer to firmware. I remember that the pressure advance has some bug several firmware version ago i decided to remove it while printing and magicaly my printer get back in good state.

    So i conclued this, if you use pressure advance you've to slow down all parameter link to motion otherwise it's overextrude in short travel.

    This is the same model where one print have pressure advance activated and not on the other one

    Sorry for this really long explanation in a really bad english, but i just wanted to explain those frustrating long time where everythings sound weird.

    Best regards,
    Hugues,



  • Is pressure advance turned on by default? (I think not, as I have understood it, but I have to ask)
    https://duet3d.com/wiki/Pressure_advance

    I'm having huge problems with overextrusion.. I can do steps/mm to 2025, but need to dial it down to 1100 to avoid huge overextrusions.

    I made a thread about it here, where I also have my configs. I have not specified M572 anywhere.
    New installation - consistently overextruding though calibrated

    Really hope someone can help, as I've spent entirely too much time on this by now.



  • I should not be by default if it's not in you start gcode or config.g but to be sur you can send M572 D0 S0 to disable it.


Log in to reply