Don't IP adress from pronterface for duetwifi



  • i am blocked to point 11: not connected to the Duet WiFi web interface, no IP adress

    M552 S0
    SENDING:M552 S0
    WiFi server stopped

    M552 S1
    SENDING:M552 S1
    WiFi server starting up
    DuetWiFiServer version 1.03 (ch fork)
    Flash size 4194304, free RAM 32608 bytes, WiFi Vcc 3.07V, host name: duetwifi, reset reason: Turned on by main processor
    WiFi is running as an access point with name DuetWiFi

    help me
    i am french, and i am a wifi from a Box Freebox
    Thanks


  • administrators

    The Duet WiFi has failed to connect to your router. Maybe you didn't enter the password correctly. Go back to step 8.



  • Thanks dc42
    I tried several times my password and always nothing
    I tried a less complicated password with protection WPA and still no success
    Protection type wifi: WPA2-PSK/TKIP protocol EAPOL V2
    canal 11, bandwidth 20 MHz , 802.11n
    the IP adress duetwifi is 192.168.1.100 when is connected, my DHCP range 192.168.0.100 to 192.168.0.140


  • administrators

    Are there any accented characters in the password? There have been reports of problems when the password contains non-ASCII characters.



  • no, there is one circumflex accent in my password
    but i already tried with one password more simple and no success
    I do not understand why the duetwifi does not connect to my wifi



  • It's not only accented characters, my Duet would not connect until I removed + and = from the Wi-Fi password.



  • ok thanks Mike
    i try with a new pasword



  • Eureka
    it works
    great thanks Mike and dc42



  • What are really the characters accepted by duetwifi? It's not very clear on the wiki
    What is the maximum length of the password?
    thanks


  • administrators

    The current firmware uses library code that I didn't write, so I don't know exactly which characters are allowed; but I can't see why characters like + and = shouldn't work because the code appears to decode them correctly. Maximum password length is currently 63 characters.

    This issue will be resolved in the new WiFi firmware that I have started writing, assuming that the bug doesn't lie in the ESP8266 SDK code.



  • ok thanks dc42
    the forum is a great tool for everyone


Log in to reply