Paneldue will not get past "connecting"



  • The paneldue 5i I have installed has worked intermittently; I have read through all the possible issues, and tried them one by one. I am utilizing the four wire connection, length was the standard one that came with it from Filastruder, and during the course of diagnosing it, I have made a short custom length with wire that tests at or under 0.1ohm, and still can't get it to connect.

    I have flashed to the latest firmware (1.23.2 on the paneldue, and 2.04RC1 on the duet). It HAS worked for a brief time - right after I flashed the upgrade. It has since returned to "connecting" on the screen.

    It WILL send the emergency stop command, causing the duet to reboot. It just doesn't seem to receive any data, and I would assume from that, won't report anything other than "connecting" until it gets a checksum properly. I have hardcoded in the config.g file the proerp baudrate, and tried both S0 and S1 parameters. I've tried the short length custom cable, with no other wires nearby, and still no go.

    Any ideas what to try next?



  • Du you have a USB-TTL adapter to try and test the serial connection to the Duet and PanelDue separately?

    Do take care to use a 3.3V TTL level



  • @bearer I do not. I can look into getting one



  • If you say the PanelDue is able to reset the Duet then that covers one direction, but to determine if its the Duet that fails to transmit or the PanelDue that fails to receive would be easier to check with a 3.3v serial port of sorts (could use an ESP8266 with ESP-Link firmware or something similar that is also 3.3v).


  • administrators

    My guess is a bad connection in the receive data line of both cables you tried, or a badly soldered Din pin on the PanelDue or badly soldered UTXD pin of the PanelDue connector on the Duet.

    Do you have a 10-way ribbon cable? if so, try using that instead (be sure to use the CONN_SD socket on the Duet, not CONN_LCD). If it's still intermittent with that cable, then the PanelDue is probably faulty, or just possibly the Duet.



  • I got it fixed.

    A stray strand of copper (I assume from when I was making my connections I didn't get all my cut strands cleaned up) had lodged under the connector housing, and likely shorting something. I didn't see it until I started looking at the solder joints with a magnifying glass.


Log in to reply