High geared (1:100) Z ; 20.000steps/mm



  • Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet Ethernet 1.02 or later
    Firmware Version: 2.04RC1 (2019-07-14b1)
    Web Interface Version: 1.22.6
    CoreXY, double Z steppers with high gear ratio (1:100)

    My machine is moving/homing, but the z-axis calibration is off..
    The reason is clear... I need 20.000 steps/mm @ microstepping=
    stepps_needed.jpg
    when using micro stepping I need even more.
    Correct_steps_mm.jpg

    All these setting are instantly stalling my Z steppers.
    So I tried multiple settings;
    https://docs.google.com/spreadsheets/d/1WQInFltVn53VTwnOhfARGDKM5ehv-s_keJl6v7CKaBk/edit?usp=sharing

    It's the double problem of not stalling the stepper and also having the correct steps/mm for Z axis calibration.
    This is so far the best setting, I found...
    config.g

    But the Z calibration is of by a factor of 20K/2640=7.57.

    Any suggestion ??



  • @wydowaw first a warning, I am no specialist of this topic!

    I see two ideas you could try: M350 is defined twice for Z, this seems strange (first setting Z to 1, then to 256 microstepping), so the effect of M92 set correctly? The second idea is that M566 speed for 1:100 for Z is very low. Torque for microstepping is very low (can be as low as 1/100 of normal torque), so this could cause stall. Your gear needs additional torque also. I would try setting Z to no microstepping as a first test.



  • how heavy is your bed that you need 1:100 gear ratio?

    with a 1mm pitch your max speed might be below what is possible on the duet 12mm/min .

    1:100 stepper motors have a speed of around 20 RPM (but i am not sure the duet can reach that).
    Your 30mm/min is above that and the motor can probably not do that speed.

    So try reducing the speed to 12mm/min



  • @JoergS5
    The first M350 is set without interpolation.
    Than M92 is set... steps/mm
    For the following M350 with interpolation, the steps are recalculated.

    An yes it works, calibration stays intact with Z256 or Z128 defined with interpolation if you do it this way.



  • @Veti

    Its a around 35kg;
    I just picked the highest gear ratio possible for a nema17.
    Just started with your 12mm/min setting.
    chrome_atXSkVqF5s.png

    The 20.000 steps start working as soon as you interpolate Z128, but Z256 is better for my hearing.
    I also calculated the steps/s/axis, which which should be <130K/s/axis

    So when z speeds hit the limit...I lose my browser connection.
    No stalling Z steppers with the working configuration in the table.

    So problem solved !!
    20.000 steps/mm are possible...
    Thanks for all the help.


  • Moderator

    @wydowaw said in High geared (1:100) Z ; 20.000steps/mm:

    interpolate Z128, but Z256 is better for my hearing.

    With the Duet Ethernet and Wifi with the TMC 2660 drivers interpolation only works when using x16 microsteps interpolated to x256. The Duet MAestro drivers will interpolate to 256 from any microstepping value.

    It's typically recommended to use x16 microsteps interpolated to x256 as you get good resolution, quiet operation, and the CPU doesn't get bogged down with high step generation. It's the best of all worlds.


Log in to reply