Duet Bed Mesh Compensation incorrectly showing Z Offset ?



  • Hi All,
    I have a BLTouch Z Probe with my Duet2Wifi for my CR10s printer.
    I upgraded to the latest firmware, web server etc and I now get the following error when ever I do a mesh bed compensation;

    G29
    Warning: the height map has a substantial Z offset. Suggest use Z-probe to establish Z=0 datum, then re-probe the mesh.
    49 points probed, min error -1.482, max error -1.175, mean -1.340, deviation 0.077

    This is the procedure I normally follow.

    (With Z offset set 0 G31 X-40 Y-10 Z0 P25 I1).

    1. Home all axis.
    2. disable axis limits. (M564 S0, G1 Z0)
    3. level the nozzle to the bed and set actual Z (G92 Z0)
    4. Work out the actual Z offset needed for the probe (G1 Z10,G30 S-1) x 5
    5. work out the average offset and then set the offset in config.g
      G31 X-40 Y-10 Z*** P25 I1 where *** = my calculated offset (positive decimal)
      6). restart the Duet.
      7). home and center.
      8). Run Bed mesh compensation

    I get the following graph from the Duet and the error message!
    MeshCompAfterOffset.jpg

    So it shows the bed as being "below Z=0"

    so it looks like the duet is mistakenly applying the offset twice ??!?

    It dose not seem to be affecting the print so it could just be an error in the software ?

    If I do a mesh compensation after setting the Z to the actual Bed I get a more reasonable result ....

    MeshCompBeforeOffset.jpg


  • Moderator

    Can you post your config.g and homing files so we can see what is being applied and when?

    Have you seen this? https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation



  • hi @Phaedrux , Thanks for the reply
    to answer your questions, No I will read it now .... not sure it existed at the time I bought my Duet. I'll see if I have done something dumb.

    [Edit: The only thing I have spotted that I don't do is cancel previous mesh bed levelling before I set the Z=0 and offset procedures, cant see that being relevant as the G92 z0 when the nozzle is on the bed sets the golden reference point ]
    ... I attach requested files

    homeall.g
    homedelta.g
    homex.g
    homey.g
    homez.g
    heightmap.csv
    config.g



  • your home scripts need updating.

    z=0 should be determined by the G30 command.
    and you will need to create deploy and retractprobe scripts

    examples from the configurator

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Sun Sep 15 2019 21:01:39 GMT+0200 (Central European Summer Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-235 Y-215 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-235 Y-215 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X15 Y15 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    for the deployprobe see
    https://betrue3d.dk/bltouch-on-duet-wifi-configuratio-and-usage/#deployretract



  • @chrishamm the configurator does not create the deploy and retract scripts at the moment.


Log in to reply