Ender 5 problems



  • I am trying to set up the Duet Maestro with my Ender 5.
    Starting with the configuration of mindoftea from this topic I was able to get the online tools working.
    Homing, heating and extruding works as expected when executed from the online access tool.

    Now when I try to print a file (test cube) I have several problems:

    • Homing Z: Z homing is really slow, it takes several minutes to home the Z axis. After the 1st homing, when the Z axis goes down, the print already starts before the 2nd Z homing is done.

    • Speed: The print speed is extremely slow compared to the stock mainboard. Still using the same Cura profile (only thing changed was Marlin->Repetier in the settings)

    • Stops: After each print move, the print head stops for about 15 seconds, plastic dripping down during that time. Print times are expected to be 12 hours instead of 30 minutes for the little test cube.

    What's going wrong here?

    Thanks a ton for your help!!!



  • Sounds to me like settings were done as if using marlin which uses mm/s instead of mm/min that reprap uses. So basically in marlin a speed of 60mm/s you would put 3600 (mm per minute) for reprap...so the accelerations, max speeds, etc are probably set wrong.

    EDIT: looking through that one line file it's hard to decipher what is going on but I don't think it is what I thought originally. You need to post up your full config.g file so it can be looked at.



  • Hi JamesM

    Thanks a lot for your reply! 🙂
    My full config.g is here:

    ; Configuration file for Duet Maestro (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Mon Sep 16 2019 16:17:21 GMT+0200
    
    ; General preferences
    G90                                                ; send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    M550 P"Ender5"                                     ; set printer name
    
    ; Network
    M552 P0.0.0.0 S1                                   ; enable network and acquire dynamic address via DHCP
    M586 P0 S1                                         ; enable HTTP
    M586 P1 S0                                         ; disable FTP
    M586 P2 S0                                         ; disable Telnet
    
    ; Drives
    M569 P0 S1                                         ; physical drive 0 goes forwards
    M569 P1 S1                                         ; physical drive 1 goes forwards
    M569 P2 S1                                         ; physical drive 2 goes forwards
    M569 P3 S0                                         ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3                                   ; set drive mapping
    M350 X32 Y32 Z32 E64 I1                            ; configure microstepping with interpolation
    M92 X160.00 Y160.00 Z800.00 E407.44                ; set steps per mm
    M566 X900.00 Y900.00 Z180.00 E120.00               ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z1200.00 E1200.00           ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E250.00               ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30                       ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                   ; set axis minima
    M208 X230 Y225 Z300 S0                             ; set axis maxima
    
    ; Endstops
    M574 X1 Y2 Z1 S1                                   ; set active high endstops
    
    ; Z-Probe
    M558 P0 H2 F120 T6000                              ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:6 Y15:195 S20                             ; define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                                   ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R2200                        ; set thermistor + ADC parameters for heater 0
    M143 H0 S80                                        ; set temperature limit for heater 0 to 80C
    M305 P1 T100000 B4138 R2200 X2                     ; set thermistor + ADC parameters for heater 1 and remap it to channel 2
    M143 H1 S250                                       ; set temperature limit for heater 1 to 250C
    
    ; Fans
    M106 P0 S0.65 I0 F20 H-1                           ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0.65 I0 F20 H-1                           ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S0.85 I0 F5000 H1 T100                     ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"Hotend" D0 H1 F0                         ; define tool 0
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    M911 S12 R20 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    
    
    

    As the homing procedure and the moves work at a decent speed when executed manually using the web interface, I don't think wrong speed settings could be the cause. It only slows extremely down when trying to print something real.
    What I will do is to check the "minimal layer time" settings in Cura as I think that could probably be the cause for the stop and wait time?



  • The first thing I would do is pep up the extruder settings a bit. Having the jerk and accelerations set so low on the extruder can cause some issues, especially if you are trying pressure advance at all which I would definitely recommend. On all 3 of my printers (Ender 3, Taz 6 and a custom CoreXY printer which all have duet wifi boards and bondtech extruders) I have instantaneous speed change of 1500 and acceleration of 1500. I don't know if the type extruder that the Ender printers come with stock can handle that high but I would bump them up to maybe 800 each as a start.

    The max speeds also seem a little slow, This is what I have set on my Ender 3
    M203 X10800.00 Y9000.00 Z300.00 E3000.00 ; Set maximum speeds (mm/min)

    I would start off there and see if there is any improvement.

    As for minimum layer time, I haven't used cura in quite a long time but I believe all that does is slow down the layer overall and not make it hang there.



  • Thanks for the tips but even after setting the speeds and accelerations that high the printer is as slow as before and it stops between every move. The problem must be something else... Probably the wrong steps/mm?



  • I don't think so...for 16x microstepping it is 80 for x & y and 400 for z, the extruder I don't remember since I don't have a stock one so 160 would be correct for 32x microstepping.

    Have you tried a different slicer? Mattercontrol, prusia slicer, etc?

    Are you using coast and wipe in cura? Maybe try turning those off.



  • I also have the Bondtech extruder but currently the stock is installed. But it seems to extrude fine with these values.
    Hmm no, I only tried Cura so far. I don't have coast / wipe enabled. I use the stock profile from Creawesome for the Ender 5.



  • Parts of Creawesome's magic is aggressive speed control, but the values sent are for Marlin (mm/sec) and as pointed out above that will be a factor of 60 slower on RRF.

    You can disable acceleration control in Cura. Maybe try that?



  • Thanks oliof, I will try it with the gcode from Simplify3D first to make sure it's not a slicer problem but a problem with the firmware on the Duet...
    I'll let you know if it worked out.



  • The problem was indeed Cura!!!
    After trying with Simplify3D the speed was fast as usual and there were no stops.
    Only thing that does not work is the part cooling fan. I don't know why this does not work as it is connected, activated in the reprap firmware and activated in Simplify3D...
    My guess is that the port is not configured correctly in reprap but where can I specify which port to use for the fan?


  • Moderator

    You should set Cura to reprap gcode flavor in the printer settings. That may solve the issue, though reprap firmware does accept the Marlin gcodes for speed, acceleration, and jerk now, so it shouldn't matter.

    What firmware version are you using?

    It sounds like you have the part cooling fan plugged into Fan port 1 maybe? It should be plugged into Fan port 0 since the slicers all tend to not specify the fan number, so having it on port 0 just makes it easier. Fan port 1 is defaulted to be the hotend fan and it will spin up briefly at power on.

    https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_fans


Log in to reply