FTP connection with curlftpfs



  • Hallo,

    i try to establish a FTP connection to my Duet2 Wifi in Ubuntu 18.04.

    First i start curlftpfs and mount the FTP to a empty folder:

    sudo curlftpfs ftp:secret123@192.168.0.99 /home/user/HevoFtp/ -v -o allow_other
    Expire in 0 ms for 6 (transfer 0x557a6e288a60)
    Trying 192.168.0.99...
    TCP_NODELAY set
    Expire in 200 ms for 4 (transfer 0x557a6e288a60)
    Connected to 192.168.0.99 (192.168.0.99) port 21 (#0)
    220 RepRapFirmware FTP server
    USER ftp
    331 Please specify the password.
    PASS secret123
    230 Login successful.
    PWD
    257 "/"
    Entry path is '/'
    ftp_perform ends with SECONDARY: 0
    Remembering we are in dir ""
    Connection #0 to host 192.168.0.99 left intact
    

    With:

    ls -al /home/user/HevoFtp/
    

    i can see the whole content of the SD card. So far so good.

    But any access (read or write) results in a Permission denied

    sudo cat HevoFtp/sys/bed.g
    cat: HevoFtp/sys/bed.g: Permission denied
    

    I also tried to establish a FTP connection with WinSCP, here there is no problem!

    Has anybody a hint for me?

    Thanks for your help!

    Here is my Hard- and Software configuration:

    Firmware Electronics: Duet WiFi 1.04
    Firmware Version: 2.03 (2019-06-13b2)
    WiFi Server Version: 1.23
    Web Interface Version: 1.22.6

    Best Regards
    Topper Harley



  • The ftp server on the duet's isn't really set up for handling multi-threaded requests which curlftpfs is trying to do. I tried a bunch of times to get it to work and to modify the RRF code to get it to work and there just aren't enough resources available to do it. If you need to synchronize local and remote directories, I'd suggest you try @wilriker 's rfm tool...
    https://forum.duet3d.com/topic/10880/rfm-reprapfirmware-filemanager-duetbackup-successor



  • That's too bad... A stable FTP connection to the Duet would be very nice to manage the whole board configuration in a git repository.

    But rfm looks like a very handy tool to create some backups or to upload file. Thanks for your help!


Log in to reply