Chiron Dual Z Help me please



  • Hello everyone, I'm new to the forum. I have a problem with Anycubic Chiron and Duet 2 Wifi. Anycubic has two optical endstops for the Z axis and I do not use the leveling probe. I perform manual leveling.
    I think I've set everything up in the best way but I can't print. I connected the first motor to Driver 2 with the respective jumpers. The other Z engine connected it to E0 - Driver 3. One endstop to Z Stop and the other to E0 Stop. I created second Z axis (U) with M584 X0 Y1 Z2: 3 U3 E4. Everything seems to go beautifully. Home XYZ all right. The two Z axes (Z and U) go home without problems. Raising and lowering Z the two engines work well in sync. Now, however, when I cast a print, only one motor moves in Z + while the other remains completely stopped. Someone could help me solve this problem. Thanks in advance to everyone.

    This is my Config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Nov 07 2018 17:54:35 GMT+0100 (centraleuropeisk normaltid)

    ; General preferences
    G21
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PChiron ; Set machine name
    M552 S1 ; Enable network
    M587 S"NETGEAR73" P"elegantsquash782" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 X goes backwards
    M569 P1 S0 ; Drive 1 Y goes forwards
    M569 P2 S0 ; 1st-zmotor (original Z) goes forwards
    M569 P3 S0 ; 2nd-zmotor - Normally used as Extruder 1
    M569 P4 S1 ; Extruder 0 goes forwards

    ;Remapping drivers for axis Z 2-3 drivers

    M584 X0 Y1 Z2:3 U3 E4 ; Driver 0 For X, 1 for Y, Z=2:4 U=4, Extruder 3 P3 not show U axis in GUI

    ; Movement setting
    M350 X16 Y16 Z16:16 E16 U16 I1 ; Configure microstepping with interpolation
    M92 X80 Y100 Z400.00:400.00 U400 E429.31 ; Set steps per mm
    M566 X900 Y900 Z300.00:300.00 E100.00 U300.00 ; Set maximum instantaneous speed changes (mm/min) (Jerk)
    M203 X12000 Y12000 Z300.00:300.00 E1200 U300.00 ; Set maximum speeds (mm/min) UU
    M201 X2000 Y2000 Z50.00:50.00 E5000.00 U50.00 ; Set accelerations (mm/s^2)
    M906 X1200.00 Y1200.00 Z1200.00:1200.00 E960 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X400 Y400 Z450 S0 ; Set axis maxima

    ; Endstop
    M574 X1 Y1 S0 ; Set Endstop and S signal
    M574 Z1 U1 S1

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0 Bed
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P2 T100000 B4725 C0.0000000706 R4700 ;T100000 B4138 C0 R47OO
    M143 H2 S285 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0
    M106 P1 S255 T45 H2

    ; Tools
    M563 P0 D0 H2 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    T0



  • Are you recombining the split Z axis into one after leveling them?

    https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors



  • @Jannakis Some obvious changes to your config.g are:

    M584 X0 Y1 Z2:3 U3 E4 P3 ; add „P3“ to hide the second Z axis (make „U“ invisible“)

    In the section „Movement setting“, remove each second Z-value (the one after the colon), as you define these for „U“ separately. NOTE that in the M906 parameters, the U value is missing: please add U1200.00

    Does homing really work? The end stops for Z are declared as active high, X and Y as active low. Looks odd to me.

    Generally, your config.g is hard to read: gcodes and comments are not always in sync., sometimes the comments tell the opposite of what the gcode does. This may result in confusion: are you sure which extruder you connected to which plug on the Duet? In gcode, you use drive3 for the second X-axis (which results in axis U) and drive4 (i.e. extruder 1 or E1) for your single extruder, but in the comments, this is mixed up. So please double check your cabling.

    I would strongly suggest that you go step by step through the gcodes in your config.g, look up the meaning of each in the wiki (and check the arguments), comment in your own words what you understand it to do - and then test each drive, heater and endstop whether it works as intended. Finally, go through your homex.g, homey.g, homez.g and homeall.g files as well.



  • @Phaedrux said in Chiron Dual Z Help me please:

    Are you recombining the split Z axis into one after leveling them?
    https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors

    Thank you, does this procedure also apply to manual leveling? That is, with the classic sheet of paper and moving the bed by hand?



  • @infiniteloop Thank you very much, then ... I checked and checked the wiring several times. The endstops of Z, unlike those for X and Y, are optical and when I enter Machine Properties they respond perfectly in the right way. The homing of XYZ does it perfectly. I connected the second Z (U) axis to Drive 3 and the extruder to Drive 4. The wiring is in place also because when I start a print the machine starts without problems. The problem is that during printing only one motor of the Z axis moves and for me this is incomprehensible since the movements and the homing Z, not in print, are executed correctly.



  • @Jannakis said in Chiron Dual Z Help me please:

    … the movements and the homing Z, not in print, are executed correctly.
    Well, if you can home all axes properly, but the second Z drive fails as soon as you start a print, you should check proper operation directly after homing: can you move the print head up and down from DWC (Duet Web Control) or with the PanelDue (if you have one attached)?

    When the second Z drive still works, re-home the printer by sending "G28" (without exclamation marks), then, test proper function of the Z drives again. If you encounter no problems up to this point, I can think of two traces to follow:

    1. The extruder (E1) might interfere with the second Z drive (E0). To check this, set your heater to 180 deg., perform some extrusion moves (either from DWC or PanelDue), then, test your Z drives again. Note however that this manual approach doesn't tell the whole story.

    2. Gcodes in the start section of the file from the slicer might mess things up. To verify the thesis, send the gcodes to your printer, one at a time, and re-check proper function of the Z drives after each step.

    If the printer passes all tests so far, try to "print" a single line: send the gcodes from the start section of your print file to the Duet, one by one, continue up to the point where the first segment of the print has just been extruded. Then, test proper operation of the Z drives again.

    Somewhere along this path, the second Z drive should fail - this point will hopefully hint you to the cause of the problem. Good luck.



  • First paragraph of my reply has gone into the citation - can't edit and re-submit. Sorry.



  • @Jannakis said in Chiron Dual Z Help me please:

    @Phaedrux said in Chiron Dual Z Help me please:

    Are you recombining the split Z axis into one after leveling them?
    https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors

    Thank you, does this procedure also apply to manual leveling? That is, with the classic sheet of paper and moving the bed by hand?

    With 2 motors moving the X gantry up and down you can only correct for tilt. It does not remove the need to level the bed using the mounting screws.

    Using mesh compensation can help correct for the bed surface irregularities, but you would still need to manually adjust the bed mounting screws. https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation

    To help automate the adjusting the bed mounting screws you can use the bed leveling assistant. https://duet3d.dozuki.com/Wiki/Using_the_manual_bed_levelling_assistant

    It would help if we could see your homing files and any bed.g if you're using G32 anywhere.



  • @Jannakis did you ever sort our your config, im trying to do my Chiron now and wondering if you can share yours?


Log in to reply