Heaters and Extruders configuration



  • Hi,
    I will start with my BED heater problem 😄 . I have printer with multiple exchangable tools so after power on, I just configure basics parameters same for all tools. After that I select Macro with specific configuration for tool (some of them include heated bed).

    After power on I would like to see no heater in Web interface. Heaters shouls be activated after I run macro, but now It seems I somehow configure Bed heater in config.g or it is self configure. Macro.jpg
    My question is how to remove BED Heater0, from WEB interface, before Macro is run.

    First BED Heater 0 is always there, Heater 1 and second Heater 0 shows after my macro.

    Second question, I can not run 2 extruders with only one hotend (dual color, one nozzle)
    I think my configuration is correct, but E0 wont feed material.
    E1.jpg
    E0.jpg

    Thank you 🙂



  • Hi

    For bed, try to disable it with M140 command in config.g (look at https://duet3d.dozuki.com/Wiki/Gcode#Section_M140_Set_Bed_Temperature_Fast ), for tool define tool with 2 drivers, like M563 P0 D0:1



  • the M140 worked, thank you 🙂
    In my mycro file I already have similar definition of extruder

    M563 P1 D0:1 H1 F0 S"Hlava 0.30"  
    

    but it does not work.



  • I see its tool 1 (P1 parameter), do you have tool 0 defined as well? From wiki "Only one tool is active at a time. To switch between tools, use the T command. Tools are conventionally numbered from zero, so in a dual nozzle printer the tools would normally be T0 and T1. The current PanelDue firmware expects the tools to be numbered T0, T1 and so on; but the web interface doesn't mind if the tools are not numbered consecutively."



  • Thank you, finaly yesterday I had a time to work on my printer 🙂 I was confuzed by the mixing extruders.


Log in to reply