SOLVED Total Strange behaviour at Core Xy Configuration



  • I have an E3D Toolchanger now i build it so far so good but. I have an issue with reliability
    It seems that the system is loosing Stepps. So i spent now whole weekend on it and need an way to measure where and why i get this situation. (i have quite experience with steppers and servos and have an HEVO 300 with duet running )
    i tried first the formum at E3D https://forum.e3d-online.com/threads/i-am-stuck-not-even-1st-print.3371/#post-33735 but it seems it might be an software and or configuration issue.

    As i wrote i can repeat the error and i can repeat a position after home but while i move the axes it gets worse and worse (on an cartesian i would play with steps per direction )
    i draw now an rig to mount an dial on the printer to be precise
    if anyone has an good idea how to tackle that error i would be verry verry happy
    i changed the name for upload to gcode they where .g homeall.gcode homez.gcode homex.gcode homey.gcode pause.gcode bed.gcode cancel.gcode brush.gcode purge.gcode
    thx thomas sleep.gcode stop.gcode config.gcode



  • what motors are on the toolchanger?

    have you tried reducing the max speed and acceleration?
    35000 mm/min max speed might be a bit high.



  • Hi
    they are the standard of E3D the motion part comes in one piece pre mounted !

    IMG_0803.jpg Finally it was an mechanic error ,..
    I don't know why i have overlooked it (maybe because i am fighting a cold an i am not 100% ,.. ) but
    on one of the X Y steppers there was one of the grub screws gone and the 2nd was not tight. So the axle is not round so in some positions
    it is driving if directions changes there was the slip !

    maybe that should make an entry in the build manual
    it is verry difficult to see you have to search for it and check it ,..
    Sorry for bothering ...
    and thank you all for the answers i learned a lot now on all the Duet M codes ;)-


Log in to reply