SD card not recognized



  • So I have a couple of Duet controlled delta's, both V.8.5 and both with 7" LCD's which I have stet up and run without much of an issue (at least regarding the Duet board connections).

    I recently purchased a Duet wifi (also with a 7" LCD) and hooked it up, however it does not want to recognize the SD card. When I power it up, the LCD fires up and it just says "Connecting…"

    Ideas?


  • administrators

    See https://duet3d.com/wiki/What_to_do_if_your_Duet_or_Duet_WiFi_won%27t_respond. If you can connect via USB but it won't read the SD card when you send M503, try another SD card.



  • Can't connect via usb to pronterface either. It just sits there spewing M105's at me. SD card is the one that came with the Duet. Haven't really touched it. I guess I can try formatting it and erasing/reinstalling the firmware.


  • administrators

    Bear in mind that most USB ports can't provide enough power for the Duet and a 7" TFT screen. When testing with USB power only, either disconnect the PanelDue, or provide separate power to the PanelDie via its USB port.



  • I have it hooked up to the PS, so it's fully powered by the 12V from the PS.


  • administrators

    Even if the SD card is not inserted, the PanelDue should connect eventually if it is configured with the standard baud rate 57600.

    When you plug the USB cable into the PC, what port appears in the PC device list?



  • It's not showing up. The USB light illuminates on the duet, but the device is not showing up in the control panel. have tried two different, known to be working USB cables.

    I also can't get into the Amtel site to download their software. They have no problem subscribing me to their lists (I've tried two different e-mail addresses), but I never get the "verification" e-mail…...


  • administrators

    I've temporarily put a copy of sam-ba 2.16 for Windows at https://dl.dropboxusercontent.com/u/19369680/sam-ba_2.16_windows.exe.



  • Thanks David. Appears as though something is seriously wrong though. I'm getting this (click on pic to see full image):



  • When you first start it you need to select the correct board and not the default you have there it should be at91sam4e8-ek instead of the at91cap9-dk_mem18



  • Yeah… the board isn't being recognized by windows. Do I have any options here other than getting another board? Tried three cables now, on two different computers, and even though the LED on the duet lights up, neither computer "sees" the duet wifi board. I have a V.8.5 board here and the computers see that just fine.


  • administrators

    Have you pressed the Erase and Reset buttons on the board?

    If yes, have you tried another USB cable?



  • Reset and erase both pressed several times and both held for 20+ seconds. Several cables tried, two of which were the brand new ones that came with the Duet and the Duet wifi. I think I'm fuxored.



  • Well, I finally had the time to figure it out.

    The problem was with the endstop switches. I unplugged everything and the duet wifi board was recognized by the computer. I then started plugging components in, one at a time and rebooting, until it had a problem.

    Stupid error on my part. I was switching over from a Duet .8.5 to the wifi and I assumed the plugs were oriented the same. Apparently the endstop switches are reversed.

    Sorry to waste your time with this. Live and learn how to read, I guess.


  • administrators

    Thanks for letting us know. I guess you must be using 3-wire endstop switches and an un-polarised connector.



  • Yeah, I'm using this one on a FolgerTech Kossel 2020 kit at my house. I've set up three other Duet's at work with no issues, but they weren't the wifi ones.


Log in to reply