Blinking bltouch



  • Ok, I have v2. Was there much improvement between v2 and v3? I just ordered another v2 (now I know - wish I had waited.).


  • Moderator

    @crchisholm the v3 is native 3v tolerant now. No more resistors or traces to cut. Not sure what other tweaks they may have made. The v2 is still very capable.



  • @Phaedrux Wow. There may be clue in this. I just got the BLTouch and to my surprise, it is a v3.1 Some time back, @dc42 had sad that I did not need to add a resistor or cut the trace any more, but he may have thought I had the v3.1. I did not cut the trace or add a resistor because of that. Even if that is the case, certainly, no blame on DC42. I did not make it clear what version I was using because I didn't know it made a difference.

    If that's the case, maybe I blew out the other two BLT's. (both v2)

    Does that sound likely?


  • administrators

    @crchisholm said in Blinking bltouch:

    If that's the case, maybe I blew out the other two BLT's. (both v2)
    Does that sound likely?

    No. You would blow a BLTouch if you applied significantly more than 5V to it. It might also be possible to blow the output driver in the BLTouch by shorting the output (white wire) to ground or to +5V or +3.3V, but without the schematic I can't say whether that is likely or not.



  • Hu-ray!!!

    The new BLT v3.1 works. After I established that, I plugged in the old ones into the new cable and they still didn't work, so I think that means that the two v2's are tiny boat anchors. I still have to unmount the old BLT and mount the new, but I suspect I will be printing again tomorrow.

    Happy Me!!!!
    Thanks for all the suggestions and help I got on this thread. Wish I could buy you all a couple of coffee and a dough nut.

    Charlie



  • Glad you have got it working again.

    How old are the others, you might be able to return them under warranty, might!

    However, brilliant and look forward to seeing your first straight print!

    Paul



  • Hey Paul,
    I looked up when I bought them and it was January of '19, so i had them a little longer than I thought. Looking at it that way, I guess that's an ok life span.

    I'm just happy to have it working.



  • This post is deleted!


  • @antlestxp said in Blinking bltouch:

    If you are into radio controlled models or drones you can plug it into a receiver and see if it works. Its just a fancy servo after all.

    That is an interesting idea. Can you tell me more about how that works. I have a RC tx and rx.



  • you would just plug the bltouch 3pin cable to a reciever. With a programmable radio you can set a toggle switch with the correct limits to toggle the bltouch in and out. I think it is pretty tough to damage a bltouch. Maybe the v2 are just configured wrong.



  • There is a possibility the set screw is t far in enough - it also serves as the steel piece that the magnet in the pin gets attracted to. Once I had an issue where it wasn’t down far enough.



  • @crchisholm, I had this exact problem, I have a v3 as well and for months this was driving me crazy. sometimes it would self test fine and then others times not.
    before powering up I would pull the pin all the way down. and then sometimes that would help assist with a successful test. Other times unplug and replug power over and over until it would self-test. This weekend I had the idea that maybe the set screw for the pin height wasn't down enough. even though I calibrated according to the documentation. So tonight I turn screw down. in between each screw turn testing with power off/on. no luck. a little bit more still not. a little bit more and dada it works every time! going to run with this and hopefully it's cured! Ah nope, worked until I had to home the Z axis. so move set screw around more and still not self-testing.
    resetting M280 P0 S60 and the M280 P0 S10 to test. blinking... voltage is good. 5.2v.

    okay I have spare PIN... put in. self-test fine. run M280 P0 S120 works good. run again. works good. run again. works good. M280 P0 S10 deploy perfect M280 P0 S90 retract perfect. Z Home perfect!

    Wondering if the magnet lost some flux...



  • I just wanted to pop in here and say how I resolved this issue of a blinking BLTouch after replacing the pin. Apparently the new pin was not properly formed when cast. After hours of troubleshooting I took the BLTouch apart, removed the pin and sanded it lightly with 400 grit emery paper. I then put a very light coat of silicone lubricant on it and reassembled. After this it worked just fine.


Log in to reply