diag light on



  • wifi module on and connected but dwc wont work, m558 z probe type 1, yat communicates with board, how do i turn diag light off and return to normal operation


  • administrators

    The diag LED shares a pin with the Z probe MOD output, so it's normal to be on when you have Z probe mode 1 selected. Mode 3 will turn it off. But it has nothing to do with DWC not working.



  • i was on dwc and hit apply setting then it rebooted and diag light came on and now i cant get on dwc


  • administrators

    I suggest you reconnect using USB and YAT, and send M552 to check that the Duet is still connecting to your router and the IP address hasn't changed.



  • i did m552 and it says wifi module connected to access point ip address is ok

    then i reentered m587 with my loggin and it still will not let me log into dwc



  • server ip address could not be found



  • how can i turn z probe to mode 3





  • @Phaedrux thank you



  • im connected to my network and ip address is 10.0.0.7 says ok
    ive done updates to firmware everything seems to be working great , i try to log into duettest.local and i get error message below.
    everything was working great then suddenly stopped ,no matter what i try nothing works, please help

    This site can’t be reached duettest.local’s server IP address could not be found.
    Try:

    Checking the connection
    Checking the proxy, firewall, and DNS configuration
    ERR_NAME_NOT_RESOLVED



  • Not teaching you to suck eggs.

    Have you tried just http://ip address instead of a name?

    I have just seen a post that Dave has fixed mDNS in 2.04RC3 which is what using a name requires.
    Personally i just use an ip address.

    HTH
    Paul.



  • @tjdehaan said in diag light on:

    i was on dwc and hit apply setting then it rebooted and diag light came on and now i cant get on dwc

    I'm guessing something you did at this point is causing the network problem, probably an error or typing mistake in your config.g. Please post your config.g so it can be checked for errors. You can do this by sending M503 in YAT, then copy and paste the text to this thread.

    Then, check your Wifi configuration. In YAT:
    Send M587 to list the stored WiFi access points.
    Send M552 to show network connections.
    Send M586 to check HTTP is enabled.
    Copy the response to this thread.

    This will show if the Duet is correctly connected. For example, my Duet Wifi shows:

    M587
    Remembered networks: 
    VM596525-2G IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0
    M552
    WiFi module is connected to access point VM596525-2G, IP address 192.168.0.4
    M586
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    

    If you get this far, then try 'pinging' the Duet. Open a command prompt and type 'ping ' followed by the Duet ip address. For me (on Mac OS) this looks like:

    ping 192.168.0.4
    PING 192.168.0.4 (192.168.0.4): 56 data bytes
    64 bytes from 192.168.0.4: icmp_seq=0 ttl=255 time=2.973 ms
    64 bytes from 192.168.0.4: icmp_seq=1 ttl=255 time=2.966 ms
    64 bytes from 192.168.0.4: icmp_seq=2 ttl=255 time=3.318 ms
    64 bytes from 192.168.0.4: icmp_seq=3 ttl=255 time=3.237 ms
    64 bytes from 192.168.0.4: icmp_seq=4 ttl=255 time=2.966 ms
    
    --- 192.168.0.4 ping statistics ---
    5 packets transmitted, 5 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 2.966/3.092/3.318/0.154 ms
    

    If it looks more like this, it's not finding the Duet, and most likely there's a network problem:

    ping 192.168.0.50
    PING 192.168.0.50 (192.168.0.50): 56 data bytes
    Request timeout for icmp_seq 0
    Request timeout for icmp_seq 1
    Request timeout for icmp_seq 2
    Request timeout for icmp_seq 3
    ping: sendto: No route to host
    Request timeout for icmp_seq 4
    
    --- 192.168.0.50 ping statistics ---
    6 packets transmitted, 0 packets received, 100.0% packet loss
    

    If you get a good ping response, you should be able to connect to the DWC by using the ip address in your browser. If you don't get a response, most likely the DWC files in the /www folder on the SD card have been corrupted. You'll need to remove the SD card from the Duet and plug it into your PC, and copy a new version of the www folder to the SD card.

    Finally, if you haven't been able to access the DWC to make changes to config.g, you should have a backup config.g on the Duet SD Card called "config.g.bak". If you remove the SD card from the Duet and plug it into your PC, copy the text from config.g.bak here as well. You could try replacing your config.g with config.g.bak; just change the names on the SD card.

    Ian



  • @PaulHew said in diag light on:

    I have just seen a post that Dave has fixed mDNS in 2.04RC3 which is what using a name requires.

    Duet 2 Wifi has had mDNS support for a long time. It's new in 2.04RC3 for Duet 2 Ethernet and Duet 2 Maestro.

    Ian



  • thanks everyone for the input, i just got home from work will be working on it , thanks again


Log in to reply