Trouble uploading files on duet wifi

  • Just did all the latest firmware upgrades, now when I go to upload a gcode file - it starts then fails anywhere from 20-50%. Is there some change that I need to make in my settings after doing the firmware upgrades?

  • did you upgrade the wifi firmware and the web controls as well?

  • yes, I just checked, and all the software numbers are current. I can log into the controller with no issues, and control it. This just becomes an issue uploading files.

  • what does the developer console of the web browser say when the upload fails?

  • Moderator

    Can you post the result of M122? Curious to see the wifi signal strength and some SD card info.

  • M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.04RC3 running on Duet WiFi 1.02 or later
    Board ID: 08DDM-9FAM2-LW4SD-6J9DL-3S86M-KJWVX
    Used output buffers: 3 of 24 (15 max)
    === RTOS ===
    Static ram: 25700
    Dynamic ram: 92748 of which 416 recycled
    Exception stack ram used: 320
    Never used ram: 11888
    Tasks: NETWORK(ready,516) HEAT(blocked,1232) MAIN(running,3740) IDLE(ready,160)
    Owned mutexes:
    === Platform ===
    Last reset 00:11:26 ago, cause: software
    Last software reset at 2019-10-13 18:17, reason: User, spinning module GCodes, available RAM 11668 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 10
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 34.6, current 34.9, max 35.1
    Supply voltage: min 24.1, current 24.2, max 24.5, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-10-13 18:28:28
    Cache data hit count 2726168254
    Slowest loop: 4.49ms; fastest: 0.07ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0, FreeDm: 160, MinFreeDm: 160, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === DDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 202.13ms; fastest: 0.08ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 2
      WiFi firmware version 1.23
      WiFi MAC address 2c:3a:e8:0b:03:97
      WiFi Vcc 3.40, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 23696
      WiFi IP address
      WiFi signal strength -67dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0

  • @Veti Network Error

  • Spent all day on this to no evail. Reset my wifi network, tried different browsers, and another computer...same results.
    The only common issue is the duet at this point.
    Bet I'm getting. Is about 500k upload speed before it times out.
    and will freeze about 20-50%.
    any ideas?

  • Moderator

    Do you have another SD card to try?

  • Just tried 2 other 4 gig cards - same result. they were both different brands as well. I even tried formatting them to both FAT32 and NTFS. No change.
    Its gotta be something in the new WIFI firmware. Ive had this board for 2 years with no WIFI issues until the last update.

  • Moderator

    Which firmware were you on before?
    Can you try rolling back to see if it works again?

  • Honestly I dont remember, I know its been at least a year since I updated this board. I thought it was time.

  • I had/have this issue since upgrading to the beta or the latest DWC - one of the two since I did both around the same time. I can get it to work when I change the printer orientation, and/or reboot my AP. It seems that it's much more finicky about signal strength or fluctuations. Eventually it can connect reliably again, after about 10 minutes from a cold startup and moving the printer so the controller board is oriented towards the AP location..

  • Just an update. I went ahead and did the ESP07-S external antenna upgrade after MONTHS of frustrations of updating and backdating firmware and drivers, etc.
    THIS is the difference - 100%!!
    2020-01-02 10_18_40-Your Orders.png 2020-01-02 10_18_40-Your Orders.png
    For $16 (for TWO sets) and some time I now have NO ISSUES with file transfer to the printer. I think this is the module that should come with the DuetWIFI from the get go. I just bought another board for a new printer, and out of the box I did the mod.
    I know they are focusing on the Duet 3 now, but if they are still going to produce the WIFI, they should consider this upgrade from the factory.

Log in to reply