Error Message: "Printer not in delta mode"



  • Hi
    My miniKossel loads the config.g file correctly.

    This file contains the line:
    M665 R104.05 L215.00 B85 H239.23 ;the numbers result from the calibration of my printer

    However the printer does not go into delta mode and does not load the homedelta.g file,

    If I issue the M665 command from the Duet Web Control G-Code Console I get the error message “Printer is not in delta mode”

    Can anyone suggest why it will not go into delta mode?

    Thank You

    Willaim Crossland



  • Have you also got an M666 command?
    Can you post the contents of your config.g?
    Which firmware are you running?


  • administrators

    @wacrossland said in Error Message: "Printer not in delta mode":

    Can anyone suggest why it will not go into delta mode?

    It probably means that you don't have a valid M665 command with delta parameters in config.g.



  • Thank you for the prompt reply.
    I attach my config.g file.
    config.g

    It contains the M665 and M666 commands which include parameters that came from the successful calibration of my printer.

    These two commands look OK and in the past did work.

    I would be most grateful if you could spot what I am doing wrong!!

    William

    P.S. I have added the commented out M584 command in order to change the driver for the Z tower, which appears to have failed. However -- I must solve the present problem before I can discover whether this works.


  • administrators

    M665 R104.05 L215.00 B85 H239.23 ; set delta radius, diagonal rod length, printable radius and homed height

    I think that command in config.g is OK, but send it the GCode console to see whether it is accepted.

    1. What firmware version are you running? Send M115 to check.


  • Your config.g shows:

    M665 R104.05 L215.00 B85 H239.23	; set delta radius, diagonal rod length, printable radius and homed height
    M666 X-0.2 Y-0.05 Z0.25			; put your endstop adjustments here, or let auto calibration find them
    

    I can't see anything wrong with this. However, earlier in your config.g you have:

    M555 P2                             	; Set output to look 
    like Marlin
    ;M584 X0 Y1 Z4 E3                 ; Move Z motor to driver 4, which is labelled E3 on the board. Original Z driver. Z motors has been moved to the E1 labelled driver position i on the board, since the original 
    

    The 'like Marlin' is on a separate line, ie there's a return in before it. Particularly in older versions of the RepRapFirmware, this could be causing the config.g to exit early, so the commands after are not processed, including M584. As this is on the next line, I expect you inadvertently put the return in when editing this line. You may have noticed other issues such as heaters/tools not defined! Try taking the return out, so the text runs back. I'm surprised you can't send the command directly, but again may be related to the firmware version you're running.

    As @dc42 said, what Duet version and firmware version are you running? Send M115 to check.

    Ian



  • I also noticed that there is no M350 command to set the micro stepping I think that means it will default but not 100% certain.



  • @Dougal1957 said in Error Message: "Printer not in delta mode":

    I also noticed that there is no M350 command to set the micro stepping I think that means it will default but not 100% certain.

    I think he’s on an older Duet 06/085, so microstepping locked at 16x.

    Ian



  • @droftarts could well be but he still hasn't confirmed firmware versions etc so hard to tell bar the ref to 0.6/0.8.5 in the config file.



  • @dc42

    The version of the firmware I am using is VERSION: 1.09k-dc42

    1. On start-up the Machine Control screen has orange Home X, Y and Z buttons (presumably as befits a Cartesian printer).
      This is despite the fact that the loaded Config File (accessed via the Settings page of the Duet web control screen) does correctly show the M665 command.

    2. Re-entering the M665 command via the G-Code Console screen results in the Machine Control screen re-setting to the version for a delta printer (i.e. only a blue ‘Home All’ button).
      Their is a long pause (shows’ busy’ on the Machine Control screen) followed by the error message “Attempt to move head of a delta printer before homing the towers”.
      Homing or moving X, Y or Z are not possible, all resulting in the same error message.

    My conclusion is the Configuration File and the M665 command are being loaded from the SD card, but for some reason the M665 cannot be processed properly.

    However I am still at a loss to know what to do.

    Thank you for your help.

    William



  • @droftarts said in Error Message: "Printer not in delta mode":

    M555 P2 ; Set output to look
    like Marlin
    ;M584 X0 Y1 Z4 E3 ; Move Z motor to driver 4, which is labelled E3 on the board. Original Z driver. Z motors has been moved to the E1 labelled driver position i on the board, since the original

    See my earlier post. Edit your config.g so the 'like Marlin' is on the same line as the M555 P2 command. By having it on a separate line, it's likely the rest of the config.g is being skipped.

    Ian


  • administrators

    @wacrossland said in Error Message: "Printer not in delta mode":

    The version of the firmware I am using is VERSION: 1.09k-dc42

    That is very old firmware! I suggest you upgrade to either version 1.25RC4 available at https://github.com/dc42/RepRapFirmware/releases/tag/2.04RC4, or 1.23 from https://github.com/dc42/RepRapFirmware/releases/tag/2.02 (it says 2.02 but the build for Duet 085 is 1.23). Don't use version 1.24, it has a bug affecting delta printers.

    After upgrading, re-test everything very carefully. It's quite likely that some changes to config,g will be needed, but going back that far I can't remember what. One of the changes that happened way back was that the default X axis direction changed (or X tower in the case of a delta).


Log in to reply