Duet prints one job, then continues to fault temp until it sits

  • So I am experiencing a kind of odd issue.

    My duet is consistantly giving me a fault of my hotend temp after a few seconds into a print. The odd thing is it has been consistant to work for one print upon its first powering on, but then cannot print due to a temp fault. I let it sit overnight and the same issue occurs.


  • administrators

    • Did you run auto tuning on the heaters?
    • What is the exact heater fault message you are getting?
    • Which firmware version are you using?

  • I may have misunderstood the problem but if some prints work OK and others give a heater fault, it is often caused by the print cooling fan coming on, blowing across the hot end and causing a sudden drop in temperature. As David has indicated, auto tuning should sort this out but if it's severe, then you could try adjusting the temperature and time anomaly settings in M570 (although if the temperature drop is severe, you may end with with a blockage so it's better to address the cause).

  • Sorry, Firmware version is 1.18 beta1,

    I am running a print again to get the error message again.

    I did do an autotune on all my heaters. I suppose I can run one again though. I just got back from class today but won't have a whole lot of time to diagnose much as of yet. Will likely go and update firmware, new autotunes and see if it helps.

    Print cooling fan is always on as I cannot get the fan controls to work for the life of me ha.

    edit: Error code still here after it sat for 3 hours:
    Error: Temperature reading fault on heater 1: temperature above limit
    Warning: Tool 0 was not driven because its heater temperatures were not high enough or it has a heater fault

    edit 2:

    Just updated firmware and webcontrol

    Doing autotune now with PWM = 1.0. Error heater faulted, went too high.

    Trying now with a p = 0.8

    Currently using a 24v Mean Well PSU with 24v heater 40w, voltage is tuned to 24v.

  • administrators

    1.18beta1 is old, I suggest you upgrade to 1.18.1.

    When you run auto tuning, the target temperature should be at least 10C lower than the temperature limit set by M143.

Log in to reply