Error: Attempting to extrude with no tool selected.



  • Hello dear community,
    Excuse me for my english ... it's Google Translate. 😉

    I have a little problem with the following error message.
    "Error: Attempting to extrude with no tool selected."

    When I start a print job, the print bed is picked up as desired and then the hotend, then the print head moves into the print bed center and takes a reading with the BLTouch and then moves outside of the print bed near the home position and extrudes slightly Filament to fill the nozzle.
    Exactly at this moment, the error message appears and no filament is extruded, but he starts directly to print.

    But if I heat up the print bed and the nozzle to the desired temperature and then start the print job, then everything works as desired and there is no error message.

    I have tried it with different firmware versions, but the error happens with each version.
    Currently I use the 2.02 ... but will update to the latest version again.

    Here is the content of my config.g file ...

    ---------------- Config.g Start ----------------
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Thu Oct 03 2019 18:54:38 GMT+0200 (Mitteleuropäische Sommerzeit)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"A5X" ; printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 F1 ; physical drive 0 goes backwards - x-achse (TOFF 1)
    M569 P1 S1 F1 ; physical drive 1 goes forwards - y-achse (TOFF 1)
    M569 P2 S0 F1 ; physical drive 2 goes backwards - z-achse links (TOFF 1)
    M569 P3 S0 F1 ; physical drive 3 goes backwards - z-achse rechts (TOFF 1)
    M569 P4 S0 F1 ; physical drive 4 goes backwards - extruder (TOFF 1)

    M564 H0 ; erlaubt das bewegen der achsen ohne referenzierung

    ; Stepper und Geometrie
    M584 X0 Y1 Z2:3 U3 E4 P3 ; dual z - kombiniert die beiden z achsen
    M350 X16 Y16 Z16 U16 E32 I1 ; microstepping und interpolation
    M92 X79.953 Y79.973 Z400.000 U400.000 E805.700 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 U12.00 E120.00 ; set maximum instantaneous speed changes (mm/min) jerk
    M203 X20000.00 Y20000.00 Z1000.00 U1000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X900.00 Y900.00 Z20.00 U20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X900 Y900 Z1200 U1200 E900 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-10.00 Y-25.00 Z0 U0 S1 ; set axis minima
    M208 X330 Y330 Z360 U360 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops (mechanic)
    M574 Z1 U1 S0 ; set active low endstops (hall sensor)

    ; Z-Probe (BLTouch V3.0 produced since 5. April 2019)
    M557 X35:295 Y35:295 S65 ; definierter messbereich / abstand (hier sind es 20mm)
    M307 H7 A-1 C-1 D-1 ; Aktivierung des PWM5-Anschluss für den BLTouch
    M558 P9 H3 F120 T10000 A7 S0.017 R0.2 B1 ; Sondeneinrichtung Schritt 1 (A5 S0.015 R0.2 B1)
    G31 P25 X-29.50 Y0.50 Z1.330 ; Sondeneinrichtung Schritt 2
    M280 P7 S160 ; BLTouch Alarm löschen (falls vorhanden)

    ; Heaters
    M307 H0 B0 S1 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B3950 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S110 ; set temperature limit for heater 0 to 110C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 I0 F500 C "Bauteile" ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off - bauteile fan
    M106 P1 S1 I0 F500 H1 T45 C "Hotend" ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on - hotend e3D V6 fan

    ; Tools
    M563 P0 D0 H1 F0: 1 ; definiere werkzeug 0 - (testweise luefter 1 entfernt (F0: 1))
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    --------------- Config.g End -----------------

    Thank you for your time and help.

    P.S. .:
    I am only since 2 weeks owner of the Duet Wifi version 1.04C
    So everything is still new and I still have a lot to learn.
    But it will be ! 😉

    A great piece of hardware !!!



  • Hi,

    Where is the gcode that does the priming of the hotend?

    We need to see that.

    Likely you are just missing a T0 command to select the tool.

    Frederick



  • Hello Frederick,

    where do I find the sequence?
    In the start area of the print job file e.g. cube.gcode, or in the start g-code area of the slicer?

    Sorry, but English is a little bit of a challenge for me and Google Translate sometimes translates very confused. 😄



  • @Günter-Jibben

    Hi,

    By "cube.gcode" are you referring to a file you are trying to print?

    I would check the gcode that the slicer executes when starting a print.

    Frederick



  • Good Morning,

    I have appended T0 to the end of the config.g file.
    Now it seems that everything works as it should. 👍

    In the Start-GCode of my Slicers (Prusaslicer) I had not entered the command T0.

    I think the problem only occurred when I entered my filaments in the web interface of the duet.
    Before that I only registered 1 filament there ... now it is 3.

    I created a file start.g in the Duet directory earlier (did not have a start.g file before) and entered the same GCode from my slicer (+ T0 at the end), but that did not work.

    I have to deal more with the file system of the Duet.
    But I have the Duet Wifi 1.04C only a few days, so it's still pretty new to me.
    Before, I used Marlin.

    Thank you for your help in the early morning.
    It is now 4 o'clock in the morning, and I have to go to bed slowly now. 😄

    Greetings from the North Sea coast of Germany



  • Hi,

    Glad I was able to be of some help.

    I've been to a few places in Europe but never made it to Germany.

    Still on my wishlist of places to visit.

    Frederick



  • @Günter-Jibben said in Error: Attempting to extrude with no tool selected.:

    I created a file start.g in the Duet directory

    start.g would need to go in the /sys directory



  • Hi,

    I've been giving this some thought.

    I don't think config.g is the best place for T0.

    You really should find the place that will always execute the T0 command at the start of a print.

    Otherwise, if by chance you deselect tool 0, you will get the error again.

    Frederick



  • @fcwilt

    nothing stopping you from putting it in both the config and the start of the g code



  • @Veti said in Error: Attempting to extrude with no tool selected.:

    @fcwilt

    nothing stopping you from putting it in both the config and the start of the g code

    I'm not the OP. I was simply making a suggestion to the OP.

    Frederick



  • Hello everybody,

    @ Phaedrux
    I had created the start.g in the sys directory.
    But I think it was not wise or correct to copy the start GCode from the slicer 1:1 !?
    Plus the T0 command at the end.

    @ fcwilt & Veti
    So far, the error message has not reappeared.

    I will deal in the near future with the file system of the duet to know which file causes what and which can be deleted if necessary.

    As I said ... I am only at the beginning what concerns the Duet.

    fcwilt helped me with the sentence ... the command T0 could be missing ... very helpful.

    This community alone is worth buying the duet.


Log in to reply