no connectivity - no blue light.



  • This is nuts! I get one thing resolved and another pops up. I feel like I'm playing whack-a-mole.

    Yesterday, I everything seemed to be working and all I needed to do was re-calibrate the BLTouch. Got tired and put it off till this morning.

    This morning, I fired up the printer (coreXY, Duet wifi) and the ESP seems to not be working. There is no blue light. The end stops are working (red light next to the axis plug responds when triggered) and the other lights are working, but I can not connect to the Duet wifi. I tried restarting the Duet several times to no effect.

    I don't know what to look at.

    Please help.
    Charlie


  • administrators

    I suggest you connect via USB and YAT (or another terminal emulator), send M503 to check that the SD card is OK, and use M552 to diagnose the state of the WiFi module.

    Does the blue LED on the WiFi module flash a few times after startup? If yes, then it could be a signal strength issue.



  • It does not flash (or come on) at all. I will do what you suggest and see what happens.



  • @dc42 said in no connectivity - no blue light.:

    I suggest you connect via USB and YAT (or another terminal emulator), send M503 to check that the SD card is OK, and use M552 to diagnose the state of the WiFi module.
    .<

    When I try to connect through YAT, I get the following error....

    An unhandled asynchronous synchronized 'ArgumentException' occurred while running YAT.
    
    YAT Final Version 2.0.0
    
    Exception:
        Type: System.ArgumentException
        Message:
            Precondition is 'min' <= 'max', but 'min' is 0 and 'max' is -1!
        Source:
            MKY
        Stack:
           at MKY.Int32Ex.Limit(Int32 value, Int32 min, Int32 max)
           at MKY.Windows.Forms.SplitContainerHelper.TryLimitSplitterDistance(SplitContainer sc, Int32 distance, Int32& limited)
           at MKY.Windows.Forms.SplitContainerHelper.PerformScaling(Control parent)
           at YAT.View.Forms.Terminal.Terminal_Shown(Object sender, EventArgs e)
           at System.Windows.Forms.Form.OnShown(EventArgs e)
           at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
           at System.Threading.ExecutionContext.runTryCode(Object userData)
           at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
           at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
           at System.Windows.Forms.Control.InvokeMarshaledCallbacks()
    

    Any idea what this means?



  • @crchisholm said in no connectivity - no blue light.:

    An unhandled asynchronous synchronized 'ArgumentException' occurred while running YAT

    https://sourceforge.net/p/y-a-terminal/bugs/434/

    Error in YAT 2.0.0. Seems like it's been fixed, current version is 2.1.0. Download: https://sourceforge.net/projects/y-a-terminal/files/

    Ian



  • @droftarts thanks

    @dc42 Ok, here's what I get with m593 and m552

    Warning: VIN under-voltage event (9.5V)
    at?
    Bad command: at?<LF>ok<LF>
    m503
    ok<LF>
    m552
    WiFi module is disabled<LF>ok<LF>
    

    Is there something I can do to enable the wifi card? (Never mind. I found M552 S1)

    I checked the power supply output and it is still at 24v, so not sure what the top line is telling me.


  • administrators

    @crchisholm, M503 is supposed to return the contents of the config.g file. The simple "ok" return when you sent it suggests that file is missing or empty.



  • Using an older backup (cant find the more recent one) I got the blue light to come on for a short time and accessed DWC. Homed the Y axis, and the light promptly went out half way home and I could no longer ping the ip.

    I have a copy of the config.g file from one of my posts on this forum. If I remember correctly, that is the only thing I’ve changed. If I find an older version of the SD, can I just update config.g, copy in the newest update file and see where that leaves me?


  • administrators

    @crchisholm said in no connectivity - no blue light.:

    Using an older backup (cant find the more recent one) I got the blue light to come on for a short time and accessed DWC. Homed the Y axis, and the light promptly went out half way home and I could no longer ping the ip.

    I have a copy of the config.g file from one of my posts on this forum. If I remember correctly, that is the only thing I’ve changed. If I find an older version of the SD, can I just update config.g, copy in the newest update file and see where that leaves me?

    Yes, you can do that. You may need to update Duet Web Control on the SD card it it is very old.


Log in to reply