Bricked Paneldue 5 v.3



  • Just completed a Railcore II build yesterday that was started last year. The paneldue worked fine until I erased it to install the latest firmware. The erase button worked but the reset button had no effect. The screen went blank but the paneldue is not recognized by Device Manager (Win7). I've tried different USB cables on 2 different Win7 PCs and the paneldue is not showing up. Is there anything else I can try to recover this?



  • does it show up as a unkown device? open the properties and have a look at the details like vendor id and device id?



  • Nothing shows up


  • administrators

    @ayudtee said in Bricked Paneldue 5 v.3:

    Just completed a Railcore II build yesterday that was started last year. The paneldue worked fine until I erased it to install the latest firmware. The erase button worked but the reset button had no effect. The screen went blank but the paneldue is not recognized by Device Manager (Win7). I've tried different USB cables on 2 different Win7 PCs and the paneldue is not showing up. Is there anything else I can try to recover this?

    Can you confirm that you have disconnected the PanelDue from the Duet, so it is connected only to your PC using the USB cable?

    Are you certain that the cables you have tried are genuine USB data cables, not USB charging cables?



  • @dc42 Thanks very much for this reply. I was not aware that there was any distinction with USB cables! The several that I had tried were all charging only. I kept trying cables until the Kindle cable did the trick.


  • administrators

    @ayudtee, I'm glad you sorted it. I'll mark this thread as solved.


Log in to reply