G30 start Gcode



  • Hi,
    I have problem to keep righr nozzel distance from bed.
    After power up printer it homes all axes and perform bed compensation

    G28   ;Z max, X & Y min
    G0 X150 Y150
    G30 ;find real Z0
    G29 S0
    

    When I start printing now without starting script it prints perfectly, but if I use G30 (starting script) it starts printing 0,8mm above bed.

    do you know why? 😄 thank you



  • We need to see the config.g, homeall.g bed.g files as well as a description of what kind of printer it is, and which duet board it is, and what firmware version you are using.



  • Yesterday I thing I found the problem. I set Home Z max to 250mm but actualy it was 250.8mm, so when I started G30 bed raised to 250 and BLTouch somehow automaticaly click itself even if the bed was still 0.8 below triggering. ???? I don't know. ( I tried disconnect Z stepper an run G30, after the printer was thinking it raised bed 250mm BLTouch clicked and printer was displaing Z = 0.0)
    Now I defined Z Max 260 and it seems working fine.

    bed.g
    config.g
    Hv6BS60.g
    homeall.g

    Board is Duet2 Wifi with firmware 2.04RC3.



  • you config does not have any settings for the bltouch.



  • sorry, I forgot. Printer works with multiple tools so config is just generic definition of machine.
    For 3D printing I am using macro Hv6BS60.g .



  • you are missing
    M574 Z1 S2



  • @Veti said in G30 start Gcode:

    you are missing
    M574 Z1 S2

    this will home to Z MIN with probe after G28, but in homeall is to home to MAX and I wold like to home to MAX 🙂
    problem was G30 and why if the printer thinks it is in Z0, it trigger BLtouch automaticaly even if Z axis was disconnected



  • you can not use z max endstop and probe at the same time.



  • @Veti said in G30 start Gcode:

    you can not use z max endstop and probe at the same time.

    Well you could use one then the other.


Log in to reply