Issues with fans come back



  • Hi,

    since time a go, dont print PLA, but yesterday i want to print a food safe piece...

    and i have discover issues with fans, layer and heatskin.

    First, i have this in config.g

    ; Fans
    M106 P0 S0 I0 F500 H1 T80               
    M106 P1 S0 I0 F500 H-1                  
    M106 P2 S0 I0 F500 H-1
    

    Second

    I have config the slicer, after layer 01, start fans, but these fans dont start, i must start its manually by DWC

    And Third

    I have discover, that although the heatskin fan starts, it does not run at full speed. This could be the cause of the jams with PETG, the fan did not cool the Heatsking... in this moments, change the speed with DWC

    Causes?



  • Hi,

    By default fan 0 (P0) is for part cooling and fan 1 (P1) and fan 2 (P2) are for extruders.

    To change that default usage you have to use M563 to define your tools and there you can specify the fan you wish to use.

    Or you can make a change in your slicer to use the desired fan.

    Frederick



  • @peirof 1 and 2 are probably because you keep using fan 0 as the heat sink fan, and fans 1 and 2 as the part cooling fans but you haven't changed your tool definition to use fans 1 and 2 instead of fan 0. I'm sure we've been through this before. I don't know why the heat sink fan doesn't run at full speed but try changing the PWM frequency (the "F" parameter) and see if that helps.

    Edit. Was typing at the same time as @fcwilt



  • Hi,

    I have changed Fans distribution, to this:

    ; Fans
    M106 P0 S0 I0 F500 H-1
    M106 P1 S0 I0 F500 H1 T80
    M106 P2 S0 I0 F500 H-1
    

    Seeing new version (not official) of Duet Web Interface i have installed.... i have see this:

    Fans.jpg

    This section seems configure the RPM, suppose of fans, similar manner like temps. No? Its well configured?

    and i have this section in Config.g

    ; Tools
    M563 P0 D0 H1					   
    G10 P0 S0 R10


  • After read Wiki... i have changed config.g

    ; Tools
    M563 P0 D0 H1 F0:2
    G10 P0 S0 R10


  • Hi,

    more info....

    after the changes in config.g.... the same, tool fans starts, but slow, if you see the pic:

    Fans2.jpg

    You can see, how the tool has reached the temp in config.g for start turning.... and the have start turning, with two issues:

    1- Throttle of tool fan in DWC, how you can see in pic, its 0%
    2- In you change throttle, in DWC, tool fan, tour faster, a lot of



  • one more try... i have changed config.g, to:

    ; Fans
    M106 P0 S0 I0 H-1
    M106 P1 S0 I0 H1 T80
    M106 P2 S0 I0 H-1
    

    i have erased F500, and now, fans are linked in DWC, if i change throttle of tool fan, change throttle of layers fans, to be the same....



  • @peirof said in Issues with fans come back:

    one more try... i have changed config.g, to:

    ; Fans
    M106 P0 S0 I0 H-1
    M106 P1 S0 I0 H1 T80
    M106 P2 S0 I0 H-1
    

    i have erased F500, and now, fans are linked in DWC, if i change throttle of tool fan, change throttle of layers fans, to be the same....

    Sorry but I do no understand what you mean by "if i change throttle of tool fan, change throttle of layers fans, to be the same".

    Thanks.

    Frederick



  • @fcwilt yes.

    Un DWC, I have 3 sliders for adjust fans...

    Before of erase F500, when I changed the percentage of any fan they were independent ... For example, I could change the from 0% to 100% tool fan and the layer fans, they remained at 0%

    After of erase F500, the throttle are linked, if I change the throttle of tool fan from 0% to 70%... The layers fans throttle too change to 70%



  • Hi,

    In your tool setup you have fans 0 and 2 specified.

    Is that correct?

    The "tool" fan is the layer fan.

    In my config.g file I don't have any M106 entries for my tool/layer fan.

    I do have an entry for that fan in a M563 command setting up tool 0 (T0), my only tool.

    It all seems to work as the slicer controls the tool/layer fan and the Duet controls the extruder fan.

    Frederick


Log in to reply