Problem with bed level with NO mesh compensation



  • Hi all,

    I've a custom Core XY, with a big bed (X390mm, Y420mm, Z400mm).

    I've a problem with bed level; I've NOT a z-probe, there are two motor for Z and they are in the bottom of printer. The toolhead is in the top but the home is in the bottom..

    I DON'T want to uso any type of bed level mesh (manual or auto), I just want to move the screws (4 points) under the bed for levelling the plane, because the structure is very rigid.

    How I can do this?

    Than, When I try to start a print, the bed remain in the bottom of printer, but the toolhead is in the top (so the printer print in the vacum).. Where I can change the setting's home?

    Thanks,
    I can annex the config.g if you want



  • @alil2096 You might consider to use a Z-probe for manual bed levelling - the concept is described here:

    Using the Manual Bed Levelling Assistant

    In addition, a Z-probe will help you to determine the proper Z=0 position of the bed - homing it at the bottom is perhaps not the best idea 😎



  • Thanks for reply.

    But there is a method for set the Z heigh without any probe?

    So, how to the ultimaker, there is a procedure for raise up the bed and move toolhead up the screws for a manual set up?.. Is in reprapfirmware a similar feature?

    Thanks 🙂



  • @alil2096

    One of my printers has manual leveling screws near the 4 corners of the bed.

    I use a 1mm thickness gauge.

    I move the nozzle to front, left.

    I raise the bed until I can just fit the gauge between the nozzle and the bed.

    I then move to the other three corners and adjust as needed to fit the gauge.

    I repeat a few times.

    Frederick



  • Ok, this is the standard procedure.

    My problem is that I don't know how set the zero of bed. I turn on the print, and then? I must send some command g-code? I don't find anythings of this procedure in documentation..



  • @alil2096

    Just out of curiosity why do you home to the bottom? Generally it would be quicker to home at the top.

    In any case you have to determine what the actual Z position is when homed.

    When you set Z axis max that is the value assigned to the Z position when the G1 H1 move (used during homing) triggers the end stop device.

    So at the point you have to move up to a known distance from the nozzle. You can do this with the thickness gauge I mentioned.

    At that point you can readout on the DWC what the firmware thinks the Z position is and compare it against where you know it is.

    Using this difference value you adjust the Z axis max setting so that moving from Z homed to Z=0 just touches the nozzle.

    For example, if you use the 1mm thickness gauge, when you are at Z=1 mm and the DWC readout is Z=5 mm you would need to reduce your Z axis max setting by 4 mm (5 mm - 1 mm).

    Frederick



  • @fcwilt said in Problem with bed level with NO mesh compensation:

    Just out of curiosity why do you home to the bottom? Generally it would be quicker to home at the top.

    the reason to do this is to be able to resume a print after power outage.
    you wont be able to home a probe with an existing print on the bed



  • Wait.. I'm trying to print, but the bed don't raise up.

    When I try to lunch the print, the heater are correctly heating, the home is ok, but when the print start the head move in XY correctly but the bed remain in the bottom of printer.

    Attach the part of config.g and homeall.g:

    Config.g
    ; Axis Limits
    M208 X0 Y0 Z0 U0 S1 ; set axis minima
    M208 X390 Y420 Z390 U390 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 U1 S1 ; set active low endstops

    ; Z-Probe
    M574 Z1 U1 S1 ; set endstops controlled by probe
    M558 P0 H370 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:375 Y15:405 S15 ; define mesh grid

    Homeall.g
    ; homeall.g
    ; called to home all axes

    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-395 Y-425 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 H1 X-395 ; home X axis
    G1 H1 Y-425 ; home Y axis
    G1 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-395 F360 ; move slowly to X axis endstop once more (second pass)
    G1 H1 Y-425 ; then move slowly to Y axis endstop
    G1 H1 Z-395 U-395 F360 ; move Z up stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 U0 ; set Z to axis minimum (you may want to adjust this)

    (the U parameters are because I've two indipendent motors for Z)

    I've try some options; the last one is change "G92 Z0 U0 " in "G92 Z-390 U-390" without resoults

    Please help me ☹



  • in the normal config both z motors need to be configured on z.

    only during homing you spliy z up into 2 axis to home them independently and at the end you combine them again.



  • Yes but the split of motor Z work very well.. My problem is that when the print start, the bed don't raise up in the top of printer but remain in the bottom..

    Why you speack about z motor split?



  • @alil2096 said in Problem with bed level with NO mesh compensation:

    G1 H1 Z-395 U-395 F360 ; move Z up stopping at the endstop

    this indicates that you configued your endstop to be at min.

    that means z=0 is when the bed is at the bottom.



  • So, I must put "0" where there is "-395"?



  • i would suggest that you recreate the config in the configurator. there are more settings that need to be changed.



  • Ok.. if there are updates for firmware I can update, for a very clear installation



  • the configurator is here
    https://configtool.reprapfirmware.org/Start

    and the information about the firmware update is here
    https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware

    find the up to date releases here (for now you should go for 2.04 firmware)
    https://github.com/dc42/RepRapFirmware/releases



  • I can't rebuild the firmaware because there are too personals settings in others voices..

    I just want fix this problem with endstop.. Do you have another ideas?



  • the location of th endstop is configured using
    M574
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M574_Set_endstop_configuration

    then you need to adjust all the movement parts in the homing script to account for a changed direction.



  • And this is clear.

    I have X and Y endstop in 0;0, and I've copy the same impostaztion for Z axis, so now when I puch the "Home All" bottom, all axes go to home correctly. So, after home process, I have all axes in 0;0;0 and I can read this in the box in the top-left of duet web control.

    My first test was that change the value of Z min from 0 to 390. So after homing I can read 0;0;390 in the box, but when the print start, Z axis go in Z-, and strains on the switch, because for my configuration Z+ in from top to bottom

    Can I change this setting? So, if I try to put Z+ from bottom to top I can resolve the problem?



  • @alil2096 said in Problem with bed level with NO mesh compensation:

    in the box, but when the print start, Z axis go in Z-,

    if you axis goes in the wrong direction you need to change the corresponding M569 command.

    also refer to this guide
    https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors



  • @alil2096

    So, after home process, I have all axes in 0;0;0 …

    … where Z=0 is at the bottom of your printer, right? Well, in order to print, the bed must be near the nozzle, that is, the first layer is always printed at (or near) Z=0. For each additional layer, Z will be incremented, which translates into the bed moving down.
    Of course you can have the Z end stop at the bottom of the printer, but this determines the maximum Z value (390 in your case?), whereas Z=0 must be at the top.


Log in to reply