Wiring NEMA 34 + Stepper Drivers to the Breakout Expansion Board



  • Hello All! I am retrofitting a large delta style 3D printer which uses NEMA 34 motors. The motors (Pamoco P85-2H-2-B-400-4) require a 48V 4A current, hence the need for the external stepper drivers. Using the Breakout Expansion board in conjunction with the Pololu 36v4 board, I'd like to drive these stepper motors. Based on my understanding of the documentation, I I believe I have the wiring correct. Documentation is here: https://www.pololu.com/product/3730

    Can someone confirm if this wiring is correct?
    Untitled Diagram (1).png

    I am away from my desk at the moment, but I can share config.g files on Monday.

    Thanks!
    -Kevin



  • @kzamani said in Wiring NEMA 34 + Stepper Drivers to the Breakout Expansion Board:

    Pamoco P85-2H-2-B-400-4

    After some further reading it looks like the driver chips need to be initialized via SPI which I did not realize. A few more follow-up questions:

    -Can the Duet initialize these DRV8711 driver chips via SPI? If so, can I wire all 4 of the chips to the same SPI0 / 1 bus to activate them?
    -How do I adjust the motor currents if I am using external drivers via SPI? Is this done via M-codes?

    Thanks!
    -k


  • administrators

    To initialise the chips using SPI, you would need to modify RepRapFirmware. Unless you have sufficient C++ firmware development experience to do that, it's probably easier for you to use an Arduino to send the SPI commands, given that Pololu provides an Arduino library.



  • I've made some progress! I purchased a similar driver from Pololu which offers the same driver chip and a USB interface to initialize the chip. Using the USB interface, I was able to setup the driver chip to run in a STEP/DIR mode and set motor currents. From what I can tell, the wiring is correct for my current setup, but there is still no motion in the stepper motor, nor is the status LED on the driver chip changing. Per the user guide, the light should be blinking in some fashion, indicating it is receiving step / direction signals.

    I believe I have a wiring issue and / or a timing issue which I do not know how to resolve. Any trouble shooting advice or corrections would be greatly appreciated.

    Additional testing notes:

    • I can drive the motors directly from the Duet(when plugged into the X/Y/Z MOT connectors) , however they will not move the carriages at slower speed and the will lose steps.
      *I have tested the same configuration with a known good Duet from another machine, running the same firmware and the issue persists.
      *I have tried a few different timing configurations, but according to the documentation, 4:2:0.5:0.5 seems to be correct
      Here is the current config.g for the machine.

    config.g



  • More progress:

    Timings set to 4:2:0.5:0.5 and now things are moving! Not sure why this mattered but, here we go.

    -k


Log in to reply