Precision Piezo Orion, Problems with meshcompensation.



  • Hi,

    i'm trying to get the mesh compensation working with the Duet Wifi on my HEVO but im close to give up.

    The problem i have is, after homing all axes i run the mesh compenstation to create the height map. (macro: "Run Mesh Bed Compensation.txt")
    if i move to x10 y10, which is my z homing position, with enabled mesh bed-compensation and adjusting now with babysteps to have a good distance between nozzle and bed i would expect that, if i move to any other position on the bed and go to Z0 the distance to the bed would be the same, since mesh compensation is active.

    this is however not the case at all. the distance is actually too huge.
    for example if i move to to x190 y160 which is the highest point in the height map, i can put sheet of paper under the nozzle and its not eave scratching it.

    at x10 y10 its OK

    it looks like that the mesh compensation is not working correctly.

    for propeing im using a Precision Piezo Orion which is otherwise working well.

    im running totally out of ideas here.
    used all different FW versions already, currently on 2.04

    Run Mesh Bed Compensation.txt
    heightmap.csv
    config.g
    Clear Mesh Bed Compensation.txt 2019-11-18 23_14_50-HEVO 300.png



  • Hi,

    Before I forget about it you should not have that M587 command in your config.g file.

    From the docs:

    Important! Do not use M587 within config.g. As well as being a security hazard, writing the access point parameters to WiFi chip every time you start the Duet may eventually wear out the flash memory. Also, the wifi module does not get enabled until the end of running config.g. It is better to use a macro to send M587

    As to you issue with mesh compensation I need to perform the same test and see if it works as expected.

    Frederick



  • @fcwilt said in Precision Piezo Orion, Problems with meshcompensation.:

    M587

    thanks a lot.

    removed the M587 from config.g, thanks for pointing this out.


Log in to reply