Change baby step value



  • Hello,
    i want to know if is it possible to change the 0.05mm value of the default baby step to another value.
    My printer has a magic number of 0.02mm so if i baby step with 0.05 my Z motor aren't in a full step position.
    I already know that i can use M290 S0.02 on Gcode console but is not fast as using the button on the DuetWebServer.
    thanks in advance



  • I can't see any obvious way to change the baby-stepping amount short of recompiling the firmware. This is where G290 is defined in the firmware, though I can't actually see where the 0.02mm comes from. Can anyone better at coding spot it?!

    However, as discussed in your other thread, this is only an issue because you're using full stepping. Better to use standard 16x microstepping.

    Ian



  • If I am not mistaking, you can change the babystepping amount in Settings>User Interface.



  • @too said in Change baby step value:

    If I am not mistaking, you can change the babystepping amount in Settings>User Interface.

    I think you might even be able to right click on the button a pick a new value. Same with the other axis jog buttons in DWC.



  • Nope, that seems to work only for the machine control workspace.



  • @Phaedrux said in Change baby step value:

    I think you might even be able to right click on the button a pick a new value. Same with the other axis jog buttons in DWC.

    I did not know that! Works on the jog buttons, but doesn't work for babystepping for me (DWC 2.0.4).

    @too said in Change baby step value:

    If I am not mistaking, you can change the babystepping amount in Settings>User Interface.

    Ah, found it, you can change it in Settings > Machine-Specific > Machine-Specific > Babystep amount.

    Ian



  • thanks a lot!!!
    i learned something new!