Stop Z from going beyond 0



  • Is it possible to force the machine to not go beyond 0 on the z axis?

    On a few occasions now we've crashed the bed into the nozzle and other equipment because the manual jog controls will allow the machine to go into the negative Z space.

    Normally this isn't too big a deal but on our large volume machine the z-axis screws are very powerful and a lot of damage occurs.

    Anyway, a soft z-stop would really help me out but I can't seem to find a setting for this.

    Worst case we'll go to hard stops but that has its own issues.

    Thanks.



  • Have a look at the axis limits in your config:

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M208_Set_axis_max_travel



  • Ha! Why do I have my M208 set to Z-780??

    🤦‍♂️

    This would have saved my buns twice now.....I never even saw that.

    X and Y are set correctly...go figure.

    Been working on this beast sporadically for almost a year...should be printing this week finally. Mind the mess and dangling wires!

    IMG_0806.JPG


Log in to reply