Cannot get DWC to load



  • Hi.
    I have not used my printers for a while but went touse them last night and I cannot get the DWC to load. The only change since I used the printers last time is I have a new router and provider but the network I use in my garage is still the same and works fine. The printers connect to the network but I cant get the DWC to load. I connected YAT to check the details andd I got the following.
    M552 S1
    <LF>WiFi module is connected to access point Wireless-N, IP address 192.168.0.24
    If I ran M587 I got a the same remenbered network but different IP address of 192.168.0.14.
    I thought it best to get rid of the remembered network so ran M588 S"*" and got rid of all networks. Ran 587 S"SSID" P"password".
    M552 S1 and I am connected to Wireless-N IP192.168.0.24 etc.
    So this is where I am getting stuck. Printer is connected to network.
    I type the IP address 192.168.0.24 and I get "Your Duet rejected the HTTP request: page not found
    Check that the SD card is mounted and has the correct files in its /www folder"
    I dont know where to go from here. Nothing else has changed.
    Any help please?
    Best regards
    Paul


  • administrators

    @preb1 what results do you get for M122 in the SD section?



  • Power off and remove the SD. Put the sd in a windows machine. Do a dir on that drive (or just open windows file explorer and do a screen shot when it is showing that drive) and post results here. Then do a dir \www and post those as well.

    Somehow/somewhere your sd either lost or corrupted the directory where DWC lives. We can fix that!



  • Thanks for the replies guys but rather embarassingly it is now working ok. I feel such an idiot. I don't know why all of sudden it works fine. The only difference is that I didn't have the usb cable connected to machine or YAT terminal open.
    Would that prevent the DWC from opening?
    Anyway at the moment I am back printing.
    Thanks again for your replies. Always nice too know there is someone there to help.
    Cheers
    Paul



  • @preb1 Nah, USB serial shouldn't hurt anything.

    That SD card may be going flakey. I'd copy it to a new, freshly formatted, card.


Log in to reply