Micro stepping delayed action



  • I have noticed lately that micro stepping (which always seemed to work fine before) doesnt change anything.

    Today I hit the button a few times with no movement on the z screws so I did the manual brute force method one step at a time on all 3 z screws, which worked great until I had to pause the print. When I resumed the print, all the buffered micro steps came into play, and the print resumed above the print surface, then would not micro step back down of course. I havent updated my FW in a while, and dont really remember this ever happening before.

    Currently running...(think im behind by one rev)

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later + DueX5
    Firmware Version: 2.03beta3 (2019-03-25b6)
    WiFi Server Version: 1.21
    Web Interface Version: 1.22.6

    Thanks...


  • administrators

    @HenryDara i guess you mean babystepping? see if you still get this in firmware version 2.04



  • Oh yeah, baby stepping. I just upgraded to 2.04, and am re-trying it. It does look like it takes a few moves before the step changes, and sometimes it doesnt seem to at all still. Gonna watch it some more, but I feel like something is still preventing it from babystepping. Mesh Bed Comp is off, and I am not trying to step below true Zero.

    Will keep at it, thanks...HD



  • What is the full step resolution of your z axis?
    What is the step size of the baby stepping you're trying to apply?


Log in to reply