Heater 1 not working - Duet 0.85 new installation



  • Hi

    I am trying to commission a Duet 0.85 on a Wanhao I3 . The bed heats up fine however I can't get the Extruder Heater to heat up. I suspect I have a config problem rather than a hardware problem.

    The temperature readings in Pronterface are showing T:B21.9 which reading thorough posts on here is showing an error code for the Extruder heater. I have checked the resistance of the thermistor and cold it is showing 180k ohms.
    My config file is for the tool 0 as follows

    M305 P0 T100000 B3950 R4700 H0 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B4388 R4700 H0 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction

    M307 H0 A193 C719.9 D8.7 B0 ; bed heater settings
    M307 H1 A219 C128 D13.9 B0 ; extruder heater settings

    ;T0
    M563 P0 D0 H1 ; tool 0 uses extruder drive 0 and heater 1
    G10 P0 S0 R0 X0 Y0 ; set tool 0 temperatures and offsets

    The heater is connceted to Heater 1 as is the thermistor

    Has anybody any idea what I can try next ?


  • administrators

    Have you sent T0 to select the hot end?



  • no I just pressed the heater button on pronterface, do I just enter T0: in the send box on pronterface or is it an entry in the config file?


  • administrators

    You can put T0 at the end of the config file if you want your printer to always start with T0 active. Alternatively enter T0 in pronterface.

    Out of interest why not connect using the web interface?



  • Thanks, I'll put the T0 into the config.
    My intention is to use the web interface, but I print in a garage and my WiFi signal is weak. I haven't got a network cable in there yet. I am looking to use a WiFi extender, but I'm keen to get my 3d printer back up and running again. Anyway the advice dc42 gave me has fixed the heater problem. So time to get steppers working now.
    Thanks again


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.