Duet Web Control temp feedback and gcode freezing



  • This is a new one for me. Only since last night have I noticed it, it may have been happening longer but I'm setting up a new machine.

    System as follows:

    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.04 (2019-11-01b1)
    WiFi Server Version: 1.23
    Web Interface Version: 1.22.6

    Windows 10 using Chrome Version 78.0.3904.108

    What brought it to my attention is when I tried to PID tune my hot end with M303 H0 S215, it heated up, cooled to 80 degrees (ish) then didn't move. So I reset the board and temps came back as ambient.

    I tried to run the M303 command again but it wont input the Gcode into the terminal. Lo and behold the temps have also frozen.

    Strangely, I can still control all axes and home, just no temp adjustments or gcode input. If I refresh DWC it will then work.

    Anyone else had an issue?



  • H0 is the bed.
    H1 is the first hot end



  • @jay_s_uk said in Duet Web Control temp feedback and gcode freezing:

    H0 is the bed.
    H1 is the first hot end

    My bad, a typo. Even with a 750w mains bed I think I'd struggle to get even half way to 215 degrees bed temp!

    It seems to freeze up when I put in gcode through the gcode console. Quite easy to replicate.


Log in to reply