Did I kill my Duet Maestro



  • Hello,

    after purchasing the Duet Maestro I connected everything to my printer and did the first test prints. Everything was looking alright. I decided to change the controll to the other side of my printer and hooked up all cables again. As soon as I powered it up all LEDs were lighting up. After a few moments I realized something was wrong but in that moment something made a "puff" sound and some smoke was coming out close to the VIN. I don't know the exact part. I guess I was a little bit to slow with the Emergency button.

    So the result is that the SD-Card got corrupted and nothing is working anymore. I can connect through the YAT but can't really change any settings. I testet the MOSFET and it seems to be alright. I can't see any damage to the board (like the square thing with U3 looks fine) and when I connect USB the three LED's (5V 3.3V and the red LED) light up.

    Is there a way to fix my board?

    It would be really depresing if I killed it one day after ariving.

    Thanks in advance


  • administrators

    Does any of the components near U3 look charred?

    Did you find a mistake in your new wiring, or do you believe it is OK?



  • Hello thanks for the quick reply.

    Everything looks fine. I was sure when I read something about the blown up MOSFET it must be this part because the smoke was close to the Port. But after checking I think the MOSFET is still okay.

    The wiring should be okay. There is just a possibality that something was wrong with one endswitch wire or the positiv heatbed wire, because that came lose while changing the side of the printer. But I soldered it back on the Heat Bed before reconnecting to the board and powering it up.

    My system runs on 12V.

    Tomorrow I will get a new small Micro SD Card and will look if the board is booting with it.


  • administrators

    When you connect 12V power with nothing else connected to the Duet (no USB), do the red 5V, green 3.3V and blue VIN LEDs light up?



  • Hello @dc42

    I just tried to just hook up 12V and ground. Like you said the three LEDs light up. I also bought a new SD Card. The Controll finds it but I wasn't able to Boot up yet.

    Best regards


  • administrators

    @markai said in Did I kill my Duet Maestro:

    Hello @dc42

    I just tried to just hook up 12V and ground. Like you said the three LEDs light up. I also bought a new SD Card. The Controll finds it but I wasn't able to Boot up yet.

    Best regards

    Please explain what you mean by "The Controll finds it but I wasn't able to Boot up yet.". How do you know that the controller finds it?

    Have you gone through https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond ?

    As all 3 LEDs light up, it sounds that U3 is still working. maybe the component that the smoke came from was a fan mosfet - does any of them look damaged?



  • Hello,

    so if I connect the Maestro via USB to my computer I find the COM port in YAT. I can also type in the M-commands. M39 is giving me the capacity of the SD-Card and M503 shows me the firmware. With M552 I can set the Ethernet but if I connect the Ethernet cable nothing happens. I can't start up the webserver. That's what I mean with I can't boot it up.



  • if you run just M552 after connecting the cable you get the IP address of the board?

    and what error does your browser give you when trying to access the IP? Timeout or HTTP/404 Not found?

    (Edit: if the SD card got corrupted, did you download the Duet web control files and put them in /www on the new SD card?)


  • administrators

    • Do the LEDs on the Ethernet socket flash?
    • Are you able to ping the IP address of the Duet?
    • Is the W5500 network chip on the Maestro getting hot?


  • @dc42 @bearer

    Hello,

    sorry I was on vacation, so I couldn't work on it.

    I replaced the SD Card and structured the folders like on the documentation written.

    If I run the M552 Code I see following:

    M552
    Network is enabled, configured IP address: 0.0.0.0, actual IP address: 0.0.0.0
    ok

    But with M552 S0 i cann't disable the network adress. There are no LEDs flashing when I connect an Ethernet Cable. I just looked closer to the W5500 and it looks like that there is a crack in the chip.


  • administrators

    It sounds to me that you had a short between +3.3V and something else, and that blew the SD card and the W5500 chip. Those two components are the ones most often blow when there is over voltage on +3.3V.


Log in to reply