Firmware 2.05RC1 released


  • administrators

    This release includes bug fixes for G2/G3 moves, resurrection of print files sliced using absolute extrusion, bed compensation when nozzle offsets are used, SCARA kinematics, and disappearing output buffers. Get it at https://github.com/dc42/RepRapFirmware/releases/tag/2.05RC1. Please provide feedback on this release in this thread.



  • Now my Scara work properly
    Thank you very much @dc42 !!!



  • @dc42 the output buffer problem seems to be solved - I ran the 40x40x6 test, and got no LF in yat, and buffers remained at 4 of 24 (17 max). Excellent work.
    However, this build does not seem to play nicely with dwc 2. I have problems changing temperature, getting error message ' select valid temperature', and manual extrusion gives a progress arrow without extruding. I tried restarting everything and clearing my browser cache, but no effect. Dwc 1 seems to be fine so far.



  • Yes I have the same problem with DWC2 temperature changes and also get the "select a valid temperature" message. I can extrude manually but only once, the extrude & retract buttons turn in to spinning arrows and don't stop.



  • I installed RC1 and in the middle of trying to fix an issue with my Bed Leveling, I now have a spinning Home button (what ever button I try to use). It keeps spinning after I press it. Also, now when I home with G1 S1 X-305 Y-305 F4000, the hotend moves slowly and the printer restarts (using stall guard). Has the S parameter been deprecated or something? Could that be my issue or something else?

    Thanks!

    Edit, using H value instead of S still causes the issue...


  • administrators

    Thanks for your reports. It turns out that DWC 2 expects every command to return at least an empty response (i.e. newline). Firmware 2.05RC1 suppresses empty responses. I'll fix this in RC2.



  • Hello,

    after update to this Version i got three times a bad print because of uncaused error "attempting print with no tool selected" while printing last 20%.
    After fallback to previous version this problem disappears.

    My configuration:
    Cartesian printer, Duet 2 wifi + due5x

    BR,
    Thilo



  • Moin (Germany's "East-Frisia" Hello or Good Day 🙂 )

    I have the same problem after homing ... infinite rotating circle ... no further homing etc. possible.
    I'm back at 2.04RC4

    Greetings from Germany's Northsea-Coast 🦀

    🎩
    😀
    👕
    👖
    👢



  • No m80 possible to activate my 24V PSU. DWC loops and Power does Not get switched on. The Same on Page General and AS gcode command.



  • @wildblue said in Firmware 2.05RC1 released:

    No m80 possible to activate my 24V PSU. DWC loops and Power does Not get switched on. The Same on Page General and AS gcode command.

    "DWC 2 expects every command to return at least an empty response (i.e. newline). Firmware 2.05RC1 suppresses empty responses." DWC 1.22.6 should work okay.

    Ian



  • Can confirm the problem with DWC2, it also gave me spurious heater fault warning on DWC2 but not on DWC1, but it could be just a coincidence as I have not been able to reproduce the heater fault. Printing at the moment will try to confirm again after print.



  • If i click in the Button in DWC to Power ATX in, i cannot Control the printer anymore. only a hard reset helps. This is reproducible.

    Printer on
    click on DWC Button,
    DWC dead.

    This dies Not Happen in FW 2.04 and is a bug, Not a feature



  • After calibrating g32, the m500 command is not displayed on the console. (but save all values) The loading process is strange. It shows immediately 100 percent and the window hangs waiting until the download actually completes


  • administrators

    All, please either use DWC 1.22.6 with 2.05RC1, or wait for 2.05RC2.


Log in to reply