Duet 2 WiFi Heated Bed not heating at all



  • Hello, I am trying to convert (against my will because of old motherboard issues, but I am adventurous) my Prusa MK2.5 Bear printer to a Duet 2 WiFi controlled machine.

    So far everything was going smoothly, motors work, endstops work, nozzle heater works, thermistors(at least nozzle) seem to work.

    The bed heating on the other hand, not budging..

    I turn on the heat to 50'C, no LED, nothing.

    I use a 12V PSU (tuned to 12.4V).

    Measuring using a multimeter from power negative -> mosfet gate it's 12.4V, power negative -> mosfet source it's 0V, power negative -> mosfet source it's 12.4V. Both bed pins are at 12.4V. Turning on changes nothing.

    Excerpt from my config:

    ; Heaters
    M307 H0 B0 S1.00                          ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700               ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                              ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700               ; set thermistor + ADC parameters for heater 1
    M143 H1 S280                              ; set temperature limit for heater 1 to 280C
    
    ; Tools
    M563 P0 D0 H1 F0                          ; define tool 0
    G10 P0 X0 Y0 Z0                           ; set tool 0 axis offsets
    G10 P0 R0 S0                              ; set initial tool 0 active and standby temperatures to 0C
    

    I have tried switching the bed cables to other orientation, nothing. Any ideas where further should I check? My board is old and has no fuse for bed, so it's not a fuse.

    Board info:

    Electronics
    Board: Duet WiFi 1.02 or later
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.04 (2019-11-01b1)
    Duet WiFi Server Version: 1.23
    
    

    The bed is a prusa MK52 magnetic bed. 0.8-0.9Ohm at room temperature. It worked with the mini rambo 1.3a before I did the switch. 🙂



  • Actually sending M140 H0 S85 by hand works. Huh.. The latest webcontrol switch to active doesn't..


  • administrators

    Please post your complete config.g file.



  • @dc42

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Fri Nov 29 2019 21:25:37 GMT+0200 (Eastern European Standard Time)
    
    ; General preferences
    G90                                       ; send absolute coordinates...
    M83                                       ; ...but relative extruder moves
    M550 P"bear"                              ; set printer name
    
    ; Network
    M552 S1                                   ; enable network
    M586 P0 S1                                ; enable HTTP
    M586 P1 S0                                ; disable FTP
    M586 P2 S0                                ; disable Telnet
    
    ; Drives
    M569 P0 S1                                ; physical drive 0 goes forwards
    M569 P1 S1                                ; physical drive 1 goes forwards
    M569 P2 S1                                ; physical drive 2 goes forwards
    M569 P3 S1                                ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                          ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                   ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E138.00       ; set steps per mm
    M566 X600.00 Y600.00 Z12.00 E150.00       ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z720.00 E7200.00 ; set maximum speeds (mm/min)
    M201 X9000.00 Y9000.00 Z500.00 E10000.00  ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30              ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                   ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                          ; set axis minima
    M208 X250 Y210 Z200 S0                    ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 S1                             ; set active high endstops
    M574 Z1 S2                                ; set endstops controlled by probe
    
    ; Z-Probe
    M558 P1 H5 F120 T6000                     ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z2.5                       ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20                  ; define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                          ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700               ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                              ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700               ; set thermistor + ADC parameters for heater 1
    M143 H1 S280                              ; set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                    ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F0                          ; define tool 0
    G10 P0 X0 Y0 Z0                           ; set tool 0 axis offsets
    G10 P0 R0 S0                              ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    


  • @Murloc992 said in Duet 2 WiFi Heated Bed not heating at all:

    i cant see anything wrong regarding your bed. however some other pointers

    M203 X30000.00 Y30000.00 Z720.00 E7200.00 ; set maximum speeds (mm/min)
    M201 X9000.00 Y9000.00 Z500.00 E10000.00 ; set accelerations (mm/s^2)

    these seem very high. are you sure you max speed is 500mm/sec? i dont think you can reach that at 12v

    ; Z-Probe
    M558 P1 H5 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height

    you need to define the correct offset and type for the pinda probe. and measure the trigger distance.

    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1

    B4138 is incorrect for prusa used thermistors.

    ; Custom settings are not defined

    you might want to add a T0 at the end for tool selection.



  • @Veti said in Duet 2 WiFi Heated Bed not heating at all:

    these seem very high. are you sure you max speed is 500mm/sec? i dont think you can reach that at 12v

    Seems like I just miss typed. This will be fixed. 🙂

    @Veti said in Duet 2 WiFi Heated Bed not heating at all:

    you need to define the correct offset and type for the pinda probe. and measure the trigger distance.

    I haven't come to that place yet, but if you have any hints, I would love to hear them.

    @Veti said in Duet 2 WiFi Heated Bed not heating at all:

    B4138 is incorrect for prusa used thermistors.

    Maybe you know what the beta values are?

    @Veti said in Duet 2 WiFi Heated Bed not heating at all:

    you might want to add a T0 at the end for tool selection.

    With a specific gcode at the custom settings section? Could you elaborate.

    Excuse my noobiness. 😄



  • T0 selects the tool for printing. without it you would need to manually select it for printing.
    The option for that is Select the First Tool on Start-Up in the tool section of the configurator.

    for z probe please read: https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe

    The termistor. if its ann original e3d its a semitec 104-gt2. in the configurator click on the beta value and a seleciton window appears.



  • @Veti said in Duet 2 WiFi Heated Bed not heating at all:

    T0 selects the tool for printing. without it you would need to manually select it for printing.
    The option for that is Select the First Tool on Start-Up in the tool section of the configurator.

    Thank you very much, seem to have missed that. 🙂

    @Veti said in Duet 2 WiFi Heated Bed not heating at all:

    The termistor. if its ann original e3d its a semitec 104-gt2. in the configurator click on the beta value and a seleciton window appears.

    Does this look better now?

    8ef243f3-3ba8-46d8-b706-fec57d28d55f-image.png

    Bed - EPCOS 100K
    E0 - Semitec 104-GT2

    The tool should really make you click all fields. 😃 I didn't even know. Tool is selected now.

    Will need to change my bed cables before I go further, but so far everything seems to go smooth. 🙂



  • Ah, I changed the bed thermistor to 104-gt2 too, so now my FLIR and the bed pretty much match up. Sweet! Prusa store notes that the thermistor is a E3D one for the bed too. 😃

    After changing the cables and setting the tool at startup everything seems to work and run very cool. Sweet!


Log in to reply