BL-Touch (clone) deploy after z-homing trigger



  • Hello, I'm about going crazy because I cant get my BL-Touch (clone by Geeetech https://www.aliexpress.com/item/32867178932.html) running.

    The sensors shows the following behaviour:

    1. power on - self test -> stays retracted
    2. homing x/y
    3. positioning to middle and deploys probe
    4. triggering the probe by hand (Z-motors not connected for safety)
    5. probe retracts
    6. homing successfull (all axis homed)
    7. probe deploys immediately after homing again and stays deployed
    • deploy and retract by using M280 P3 S10 I1 / M280 P3 S90 I1 works perfectly
    • test mode M280 P3 S60 I1 and deploy works fine -> Z-Probe in web GUI shows 1000 and probe stays retracted!
    • 240 OHM resistor between GND and IN
    • tightening and loosening the screw on top of the BL-Touch showed no change of the behaviour

    The BL-Touch is installed on a BLV MGN Cube built up. I am running my duet V1.04 on firmware version 2.04.
    I am really running out of solutions because in every way the BL-Touch works fine manually just not when its about to do its real job.
    Could this be a hardware problem? I have already checked the signal with a oscilloscope and it dosnt look bad.
    My last idea is that its any kind of software issue because by controlling the BL-Touch manually everything works.

    Please let me know if you have any ideas.

    // config. file

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 09 2018 13:27:56 GMT+0300
    
    ; General preferences
    M80				; Turns on the ATX power supply
    G90                                                ; Send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    
    M667 S1                                            ; Select CoreXY mode
    
    ; Network
    M550 PBLV mgn Cube                                 ; Set machine name
    M552 S1                                            ; Enable network
    M587 S"your_wifi_name" P"your_password"            ; Configure access point. You can delete this line once connected
    M586 P0 S1                                         ; Enable HTTP
    M586 P1 S0                                         ; Disable FTP
    M586 P2 S0                                         ; Disable Telnet
    
    ; Drives
    M569 P0 S1                                         ; Drive 0 goes backwards blv: its was S1
    M569 P1 S1                                         ; Drive 1 goes backwards blv: its was S1
    M569 P2 S1                                         ; Drive 2 goes forwards
    M569 P3 S1                                         ; Drive 3 goes backwards WAS 0
    M350 X16 Y16 Z16 E16 I1                            ; Configure microstepping with interpolation
    M92 X200 Y200 Z400 E405.18                         ; Set steps per mm for Bondtech. 
    M566 X600 Y600 Z24 E300                            ; Set maximum instantaneous speed changes (Jerk) (mm/min) 
    M203 X20000 Y20000 Z600 E2000                      ; Set maximum speeds (mm/min) 
    M201 X3000 Y3000 Z100 E5000			   				 ; Set accelerations (mm/s^2)
    M906 X1600 Y1600 Z1600 E1600 I30                   ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Pressure advance
    ; M572 D0 S0.05					   					; disabled Pressure advance
    
    ; Axis Limits
    M208 X-23 Y0 Z0 S1                                 ; Set axis minima
    M208 X320 Y321 Z350 S0                             ; Set axis maxima
    
    ; Endstops
    M574 X1 Y2 S1                                      ; Set active high endstops edit: Y endstop is high(max).
    
    ; Filament sensor
    M591 D0 P1 C3 S1				 					  ; Set Filament sensor Simple type (High) for extruder drive 0, connected to endstop input 3 (E0)
    
    ; Z-Probe
    M574 Z1 S2					 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1				 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 				 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X28.5 Y-5 Z0.75				 ; Set Z probe trigger value, offset and trigger height
    M557 X40:330 Y40:300 S40			 ; Define mesh grid
    
    ; Heaters
    M305 P0 T100000 B3950 C0 R4700                     ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100                                       ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B3950 C0 R4700                     ; Set thermistor + ADC parameters for heater 1
    M143 H1 S260                                       ; Set temperature limit for heater 1 to 260C
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                             ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T35                          ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T35                          ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                                      ; Define tool 0
    G10 P0 X0 Y0 Z0                                    ; Set tool 0 axis offsets
    G10 P0 R0 S0                                       ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic power saving
    M911 S21 R22 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss
    
    ; Custom settings are not configured
    M564 H0                                   	   ; Let the Jog buttons work blv: added to allow jog buttons
    

    // retractprobe.g

    M280 P3 S90 I1		;retract probe
    G4 P200			;delay 200ms
    

    // deployprobe.g

    M280 P3 S10 I1		;deploy probe
    G4 P200			;delay 200ms
    

    If I missed any information which could be useful let me know!
    Thanks for the support!



  • What do you have in homeall? Just a G30 to probe?

    Have you tried removing the G4 delay from the probe files?



  • my homeall.g has the following code:

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 09 2018 13:27:56 GMT+0300
    G91                     ; relative positioning
    G1 Z5 F6000 S2          ; lift Z relative to current position
    G1 S1 X-355 Y355 F6000  ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-355             ; home X axis
    G1 S1 Y355              ; home Y axis
    G1 X5 Y-5 F6000         ; go back a few mm
    G1 S1 X-355 F360        ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y355              ; then move slowly to Y axis endstop
    G90                     ; absolute positioning
    G1 X152 Y166.4 F6000 	; go to first bed probe point and home Z
    G30                     ; home Z by probing the bed
    
    ; Uncomment the following lines to lift Z after probing
    ;G91                    ; relative positioning
    ;G1 S2 Z5 F100          ; lift Z relative to current position
    ;G90                    ; absolute positioning
    

    Yes I have alredy tried without the delay - actually I put the delay in there when I tried to figure out the problem. But I will try to remove them and see if it has an impact.
    Thanks!
    EDIT: removed the delay from deployprobe and retractprobe - same behaviour



  • The G4 delay is the only thing that doesn't match my own configuration. Everything else looks correct. Since the behaviour seems mostly correct it would then lead me to conclude that it's wired correctly. That only leaves the fact that it's a clone.



  • @Phaedrux I agree with you that this is kinda strange and most likely because of the shitty clone. But what makes me curious is the fact that it works perfect with manual commands and not in the "automatic" mode.



  • Found something that might be interesting. When using the commands M401 (deploy) and M402 (retract) only the M401 deploy command seems to be functional. With the command M280 P3 S10 I1 etc. as in deployprobe.g and retractprobe.g it works for deploy and retract.

    Could it be that the not working M402 has something to do with that the pin doesnt stay retracted?



  • Can you try recreating the deploy and retract files from scratch?



  • @Phaedrux Thanks man! I don't know why but it looks like its working now!


Log in to reply