Layer change



  • I have a small problem with my Kossel Mini based on Duet 0.85.
    At the layer change point(s) always a small over extrusion seems to occur that flattens after some time.

    Please see the magnified picture. In reality the distortion is much less visible and overall print quality pretty OK.

    I tried with both S3D and Cura virtually any possible setting (retraction at layer change, coasting, extra restart distance, wiping), different retraction length and speed, firmware retraction, pressure advance, different jerk and acceleration values, almost everything I could imaging. Also when printing with very low speed e.g. 30 mm/s the problem remains visible.

    Any ideas what else to tune?


  • administrators

    Try searching for "Z banding" in the general 3D printing forums, such as http://forums.reprap.org/list.php?262. It looks to me that the print direction is alternating between layers except for the top few layers, and you have backlash in the axis that corresponds to the left-right direction in that print.



  • Thanks for the hint. Any idea what to check/tune on the Delta? Printer is a Kossel Mini Kit from T3DP3D.
    The ringing is not constant but decreasing after the layer/direction change.


  • administrators

    Is there any play in the joints? If so, use springs to take it up. When I was using Traxxas joints, I was able to invert the rods so that all the loose joints were at the effector end. Then I added a spring between each pair of arms at the effector end.

    What XYZ motor current are you using?



  • As far I see there isn't any play in the joints.
    The motor current is the default one.

    M906 X1000 Y1000 Z1000 E800 I60 ; Set motor currents (mA) and increase idle current to 60%

    –----

    The printer object is a simple 25x35 mm test cube with rounded edges.

    I monitored the print and found that the outline direction isn't alternating. Instead the starting point of the outline is moving to the opposite side with each layer, caused by the infill pattern ending. At both sides the start of each new outline looks slightly over extruded. After approx. 15 mm the outlines are better stacked again but the difference to the object with concentric infill (see below) remains visible around the whole object.

    I made a second print 90° rotated with exactly the same symptoms.

    Using a concentric infill (Cura 2.4) where each outline starts at same point will solve the issue. The layers are stacked perfectly smooth without any ringing.
    Using the Cura Option Outer before inner walls will make the results much better as well but still less perfect than the concentric infill.

    Upper item concentric infill, lower grid.


  • administrators

    If the start looks over-extruded or a short distance,, you may be using too much pressure advance.



  • There was no pressure advance (M572) applied …



  • I've got the exact same thing, can't seem to find any settings that'll get rid of it, S3D or Slic3r.

    Using a Duet Wifi on a coreXY not a delta.

    I too am not using pressure advance.

    If you ever get to the bootom of it please let me know, cheers.



  • I made a lot of more tests and for me the problem seems to be related to the speed difference between infill and walls or between inner outer wall(s).
    When printing the object with constant speed, even high one (e.g. 80 mm/s), for all features the quality is better than with different infill/wall speed.

    Also printing more walls is not helpful but identical speed for all walls will improve the quality as well.
    In summary my printer, hotend (E3D V6) or settings can not handle speed changes well with respect of constant extrusion.

    As far I understand pressure advance should be a solution for such issues however not for me (tried various settings).

    My solution for now: infill at 80 mm/s, three walls at 40 mm/s.


Log in to reply