Homing fails on printerbot



  • This is the position where all endpoints are being triggered:

    IMG_20191202_195330.jpg

    This is the opposite position of the endpoints:

    IMG_20191202_195341.jpg

    And I've been through your links, and I do see the endpoint status switching from yes to no in the machine settings when I move the bed and extruder



  • If you send M119 in the gcode console with the endstop switches not pressed, what does it reply with? And if you manually depress the switches, what does it reply with?



  • M119 without endstops pressed:
    Endstops - X: not stopped, Y: not stopped, Z: at min stop, Z probe: at min stop

    M119 at endstop position:
    Endstops - X: at min stop, Y: at max stop, Z: at min stop, Z probe: at min stop



  • your homing files require at least firmware version 2.03

    which one are you running?



  • I'm running on 2.0.4



  • So the Z endstop shows as activated even when it's not activated?



  • @Phaedrux I didn#t move the Z, it's probably just still activated because it's so low. I wanted to make X and Y work first



  • Can you try modifying your homing files to remove the H2 from the second back off movements for X and Y?

    ex: G1 H2 X5 F6000 ; go back a few mm



  • I tried that but it doesn't seem to help. I get an error saying "Insufficient axes homed"



  • Mind you I only mean the moves that have X and Y movement. The move to lift Z at the start would stay the same.

    If you're still getting that error message after only removing the H2 from the X and Y moves it would tell me that the X and Y axis are not actually getting homed on that first pass.



  • Yes that's what I did. Only for the X and Y moves, but they don't get properly homed


  • administrators

    Something isn't right with your config. You indicated that the position where the X and Y homing switches get triggered is the corner of the bed marked with an X. That must be either X0 Y0 or X160 Y160. Assuming it is the bed that moves in Y and the print head that moves in X, as things stand your config says you have the X endstop at X0 and the Y endstop at Y160, which if those coordinates are where the X is, would give you mirrored prints.



  • @dc42 Oh I see. I just configured it until it moved to 0,0. But I probably made a mistake with the endstop location. But still, it should stop when the endpoint is triggered, right?



  • on moves that have the parameter H1.
    if you really have a recent firmware.

    are you sure that you did not swap x and y endstops?
    what kind of endstops are they?


Log in to reply