[DSF Extension] Exec On MCode (was: Shutdown SBC)



  • Shutdown SBC v1.0

    A small extension to listen for a user-defined M-Code (M7722 by default) to then initiate a clean shutdown of the SBC (it simply executes poweroff - and since it's usually run as root that will work).

    It can be found at GitHub Releases page.

    Usage

    $ shutdownsbc --help
    Usage of shutdownsbc:
      -shutdownMCode int
    	  Code that will initiate shutdown of the SBC (default 7722)
      -socketPath string
    	  Path to socket (default "/var/run/duet.sock")
    

    Installation

    • Download
    • Rename to just shutdownsbc
    • Make executable with chmod +x shutdownsbc
    • Put it into any path in your $PATH e.g. /usr/local/bin
    • Run it as root or with sudo
    • Optional: use the shutdownsbc.service systemd unit (included in the repo) to run it at startup

    Source Code

    You can find it at https://github.com/wilriker/dsfext-shutdownsbc

    Contribution

    As always I welcome any kind of contribution here or over at GitHub. Comments, suggestions, bug reports, Pull Requests, whatsoever. Everything is appreciated.



  • Exec On MCode v2.0

    After a request on GitHub to also make the command to run configurable I have renamed the whole project to execonmcode and created a new release that will make the command configurable.

    It will also report the outcome of the command (success, error) back to DuetSoftwareFramework.

    As usual it can be found at GitHub Releases page.

    Usage

    $ ./execonmcode --help
    Usage of ./execonmcode:
      -command string
            Command to execute
      -mCode int
            Code that will initiate execution of the command (default 7722)
      -socketPath string
            Path to socket (default "/var/run/duet.sock")
    


  • @wilriker Great work, the plugin works just as it should! 👍
    We're using it to build a 'move backwards in gcode' function. However, it would be great if we could bring variables into the command string, maybe that could be solved by giving the M code S, P and Q parameters that would translate into $S, $P and $Q?



  • @too Thanks! I saw your GitHub issue but was a bit busy the last days. Sorry for not getting back to you sooner. Also great to hear that it is actually used by someone other than myself. 🙂

    I'll think about how to do that best.



  • @wilriker Now RRF3 just needs to be working smooth with some of the more exotic features and the system would be near perfection 😁


  • administrators

    @too said in [DSF Extension] Exec On MCode (was: Shutdown SBC):

    @wilriker Now RRF3 just needs to be working smooth with some of the more exotic features and the system would be near perfection 😁

    I expect to release RRF3 RC1 very soon.



  • @dc42 looking forward!



  • Release v2.1

    This release provides parameter substitution. Please see the below for details on how to use it.

    It can be found at the GitHub Releases page.

    Parameters

    execonmcode does provide a simple mechanism for parameter substitution. It is possible to pass string parameters to the
    selected M-Code and have them inserted in the -command. In the command string they have to be single letters prefixed by
    the percent-sign (%) and they must not be G, M or T.

    All parameters that do not have a corresponding value in the M-Code will be forwarded as given.

    Example

    Run execonmcode as

    $ ./execonmcode -command "mycommand %F %N %D"
    

    Then you can use the following M-Code syntax to replace these parameters

    M7722 F"my first parameter" N"my second parameter"
    

    this will lead to an execution of

    mycommand "my first parameter" "my second parameter" %D
    

    Note that %D was passed as is since it was not given in the M-Code.



  • Release v2.1.1

    This is just a bug fix release to address a bug where too many (empty) parameters where introduced in between the command and it's actual parameters. This could lead to various problems.

    As usual it can be found at GitHub Releases page.

    Thanks to @too for reporting this. 👍



  • Just as a short teaser: the upcoming version will allow an arbitrary amount of M-code+command pairs.



  • great Job !! many thanks.
    exactly what I looked for

    Tobias



  • Release v3.0

    This release adds the possibility to provide an arbitrary amount of -mCode + -command tuples. This way it is possible to have a single instance of execonmcode handle all the custom commands.

    Note that as part of this change there is no longer a default value for -mCode.

    Get it at GitHub Releases page.

    EDIT: This version is built agains goduetapiclient 1.2.0 and as such will only work with DSF 1.2.2.1 and later. In case you need a version that is working with DSF <= 1.2.2.0 please tell me here. It's not a problem to provide that as well.



  • @wilriker I can't believe I missed this whole thread! Gonna give it a try tomorrow.

    I'm also working on something to allow the SBC to do a hardware reset and flash erase via GPIO pins for cases where the firmware is stuck and you can't get to the board. Could be a good companion to your utility.



  • @gtj0 Glad to hear about any use-cases. 🙂

    I myself use it to run poweroff as well as activating and deactivating my webcam (starting/stopping a systemd unit).



  • Tempting to try with a small I2C OLED on the Pi, but not top of the list just yet



  • @wilriker

    This sounds really good. I would like to use it to activate a bash script on my system but I have attempted to install it and I cant get it to work.
    I followed your instructions in your first post but using execonmode V3:

    I downloaded execonmode and placed it into /usr/local/bin.
    I tried to run it using sudo ./execonmode -help (just to see if it works) but I get the error message "cant open binary".

    Could you instruct me where i'm going wrong.

    BTW I am on the latest version of RRF3 and up to date with DSF etc.

    Thanks in advance.



  • @chas2706 If you run

    sudo ./execonmcode -help
    

    It will try to find the executable in the current directory you issue this command. To have your shell locate it in your $PATH remove the ./ in front of execonmcode. For -help you don't need sudo BTW.

    To make sure that it can find it also check if

    echo $PATH
    

    actually does contain /use/local/bin.

    Last thing: you spelled it execonmode instead of execonmcode (extra "c" after "m") above. Make sure that's only a typo here. I might rename the executable in the future to something less error-prone.



  • @wilriker
    Thanks for the info. I will give it another go.

    execonmode was just a typo error in my post lol.

    Thanks



  • @wilriker said in [DSF Extension] Exec On MCode (was: Shutdown SBC):

    ./execonmcode -help

    I have placed execonmcode in /usr/local/bin and typed the following in the terminal without success:

    pi@Duet3:~ $ cd /usr/local/bin
    pi@Duet3:/usr/local/bin $ ls
    execonmcode listen-for-shutdown.py
    pi@Duet3:/usr/local/bin $ ./execonmcode -help
    bash: ./execonmcode: Permission denied
    pi@Duet3:/usr/local/bin $ sudo ./execonmcode -help
    sudo: ./execonmcode: command not found
    pi@Duet3:/usr/local/bin $ execonmcode -help
    bash: /usr/local/bin/execonmcode: Permission denied
    pi@Duet3:/usr/local/bin $ sudo execonmcode -help
    sudo: execonmcode: command not found
    pi@Duet3:/usr/local/bin $



  • @chas2706 Have you made execonmcode executable via sudo chmod +x /usr/local/bin/execonmcode? I think that's missing from the installation instructions.


Log in to reply