Have to run G code file twice to begin print at correct height



  • Hi guys
    I have this issue where I send the g code file to the duet wifi, and all is well until it starts to print. The nozzle tip is quite a few mm above the heatbed, I cancel, start another, then its perfect. Any clue why this is ?
    I have posted below, config, home all, home z, and a snippet from the beginning of the code file
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Wed Nov 27 2019 02:27:21 GMT-0500 (EST)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"ALPHA 300" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z1600.00 E311.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z300.00 E4200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X1050 Y1050 Z1250 E1050 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X300 Y300 Z190.19 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 Z2 S0 ; set active low end endstops

    ; Z-Probe
    ;M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    ;M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S80 ; set temperature limit for heater 0 to 80C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S260 ; set temperature limit for heater 1 to 260C

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned OFF
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned ON
    M106 P2 S1 I0 F500 H-1 ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned OFF

    ; Tools
    M563 P0 S"NOZZLE " D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ————————————————————————————————————————

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Wed Nov 27 2019 02:27:21 GMT-0500 (EST)
    G91 ; relative positioning
    G1 H2 Z5 F300 ; lift Z relative to current position
    G1 H1 X-305 Y-305 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-305 Y-305 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G1 H1 Z195.19 F300 ; move Z up stopping at the endstop
    G90 ; absolute positioning
    G92 Z190.19 ; set Z to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    ————————————————————————————————————————

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Wed Nov 27 2019 02:27:21 GMT-0500 (EST)
    G91 ; relative positioning
    G1 H2 Z5 F300 ; lift Z relative to current position
    G1 H1 Z195.19 F300 ; move Z up until the endstop is triggered
    G90 ; absolute positioning. added extra line could remove for testing
    G92 Z190.19 ; set Z position to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 H2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    ————————————————————————————————————————

    ;FLAVOR:RepRap
    ;TIME:44156
    ;Filament used: 9.62041m
    ;Layer height: 0.2
    ;Generated with Cura_SteamEngine 3.6.0
    T0
    M190 S60
    M104 S210
    M109 S210
    M82 ;absolute extrusion mode
    G90 ; Absolute Position
    G28 ; Home ALL axis
    G1 X30 Y30 Z170
    G92 E0 ; Reset extruder
    G1 X30 Y30 F4000 ;move X/Y to front of printer
    G1 Z15.0 F9000 ;move the platform to 15mm
    G4 5000
    G92 E0 ;zero the extruded length
    G1 F200 E50 ;extrude 10 mm of feed stock
    G4 10000
    G92 E0 ;zero the extruded length again
    G4 1000
    M83 ;relative extrusion mode
    G1 F1500 E-6.5
    ;LAYER_COUNT:401
    ;LAYER:0
    M107
    G0 F7500 X165.65 Y76.023 Z0.16
    ;TYPE:SKIRT
    G1 F1500 E6.5
    G1 F900 X165.918 Y75.542 E0.00552
    G1 X166.252 Y75.104 E0.00553
    G1 X166.647 Y74.72 E0.00553
    G1 X167.093 Y74.396 E0.00553
    G1 X167.581 Y74.141 E0.00552



  • I would guess that it's due to homing to Z max and the homed height being set with G92 Z190 is not exactly correct?


Log in to reply