Problems with Bed Leveling , need some help to understand



  • Hi

    i have the Duet Wifi with latest Firmware.
    On my Cartesian 3d-Printer

    Z-Probe with Piezo Orion

    i use 2 independet Z-Motors

    Thats my bed Levelig with 4 point at each Corner

    this my config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Apr 11 2019 17:51:12 GMT+0200 (Mitteleuropäische Sommerzeit)
    
    ; General preferences
    G90                                      ; Send absolute coordinates...
    M83                                      ; ...but relative extruder moves
    
    ; Network
    M550 P"AM8"                              ; Set machine name
    M552 S1                                  ; Enable network
    ;M587 S"WLAN-110995" P"3951006964710671890"  ; Configure access point. You can delete this line once connected
    M586 P0 S1                               ; Enable HTTP
    M586 P1 S0                               ; Disable FTP
    M586 P2 S0                               ; Disable Telnet
    
    ; Drives
    M569 P0 S0                               ; Drive 0 goes forwards X
    M569 P1 S0                               ; Drive 1 goes forwards Y
    M569 P2 S1                               ; Drive 2 goes backwards Z
    M569 P3 S0 				 ; Drive 3 goes forwards Extruder
    M569 P4 S1 			         ; Drive 4 2nd Z-motor - Normally used as Extruder 1
    
    ; Motor Remapping
    M584 X0 Y1 Z2:4 E3	; two Z motors connected to driver outputs Z and E1
    
    
    M350 X16 Y16 Z16 E16 I1                 ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E407.92	; set steps per mm
    M566 X600.00 Y600.00 Z120.00 E300.00      ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z600.00 E6000.00  ; set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z240.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X1400.00 Y1400.00 Z1400.00 E1120.00 I30            ; set motor currents (mA) and motor idle factor in per cent
    M84 S30  ; Set idle timeout                             ; Set idle timeout
    
    
    ; Axis Limits
    M671 X-106:106 Y0:0 S0.5 		 ; leadscrews at left and right of X axis für 2 motoren
    M208 X-129 Y-121 Z0 S1                   ; set axis minima
    M208 X120 Y110 Z240 S0                   ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 S0                            ; Set active low and disabled endstops
    M574 Z1 S2                               ; Set endstops controlled by probe
    
    ; Z-Probe
    M558 P1 I1 H5 R0.5 F420 T6000			 ; Set Z probe type to effector and the dive height + speeds
    G31 P545 X0 Y0 Z-0.142                      ; Set Z probe trigger value, offset and trigger height 
    ;M557 X-104:106 Y-99:99 S40                 ; define mesh grid
    M557 X-104:106 Y-99:99 P2                     ; 4 Punkte Bett Leveln
    
    
    ; Heaters
    ;M307 H0 B0 S1.00                         ; Disable bang-bang mode for the bed heater and set PWM limit
    ;M307 H0 A78.5, C355.9, D1.0	          ; Pid Tuining BED
    ;M143 H0 S130                             ; Set temperature limit for heater 0 to 130C
    
    M305 P0 T100000 B4138 R4700              ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                             ; Set temperature limit for heater 0 to 120C
    
    
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S250                             ; Set temperature limit for heater 1 to 275C
    M307 H1 A224.6, C134.6, D5.3 S1		 ; Pid Tuning -nozzle
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                   ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                            ; Define tool 0
    G10 P0 X0 Y0 Z0                          ; Set tool 0 axis offsets
    G10 P0 R0 S0                             ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    
    ; Miscellaneous
    T0                                       ; Select first tool
    ;M501
    

    height map 4 Points:

    RepRapFirmware height map file v2 generated at 2019-12-22 12:32, min error -0.008, max error 0.005, mean -0.001, deviation 0.005
    xmin,xmax,ymin,ymax,radius,xspacing,yspacing,xnum,ynum
    -104.00,106.00,-99.00,99.00,-1.00,210.00,198.00,2,2
      0.002,  0.005
     -0.003, -0.008
    

    looks ok for me

    1.png

    thats my bed with 30 Points

    2.png

    RepRapFirmware height map file v2 generated at 2019-12-22 12:36, min error -0.035, max error 0.055, mean 0.006, deviation 0.022
    xmin,xmax,ymin,ymax,radius,xspacing,yspacing,xnum,ynum
    -104.00,106.00,-99.00,99.00,-1.00,40.00,40.00,6,5
      0.030,  0.010, -0.005, -0.000,  0.010,  0.042
      0.030,  0.010, -0.005, -0.010, -0.005, -0.000
      0.015, -0.003, -0.023, -0.035, -0.030, -0.025
      0.015, -0.000, -0.023, -0.018, -0.005,  0.007
      0.032,  0.025,  0.022,  0.030,  0.037,  0.055
    

    the first layer prints in the air

    i do first:

    Home X and Y axis
    Go to the middle of bed and do G30
    G32 to level 2 independet 2 Z Motors
    and then i print

    my home 0,0 is in the middle of my bed

    is this correct or i make errors ?

    i hope someone can help me

    thanks



  • try
    homeall
    g32
    homez
    then g29

    but if the print is in the air, you will need to adjust the z trigger height of your probe.
    adjust with babystepping until you get a good first layer, then change the offset by the babystepping ammount.

    M671 X-106:106 Y0:0 S0.5 ; leadscrews at left and right of X axis für 2 motoren
    M557 X-104:106 Y-99:99 P2 ; 4 Punkte Bett Leveln

    The location of the leadscrews seem wrong, that would put them inside your probing area.



  • sorry for late answer

    i have try but it is still the same issue with mesh

    4 point:
    4point.png

    and the 36 Point mesh
    36point.png

    whats the problem here ? why the bed is not flat like the 4 point ?

    thanks



  • A 4 point mesh will always be flat as the controller connects the 4 points with straight lines. It does not represent the true shape of the bed.
    I would be VERY happy with a bed as flat as the one shown with 36 points !!!


Log in to reply