Mini IR Probe configure issue



  • I am having difficulties installing the Mini IR Probe with the Duet Maestro mainboard.

    When powered on the LED Blinks Twice & not 4 times.
    This means the device is not in analoge mode.

    When I put an object near the sensor the LED indicator goes on.

    Inside the Web Control I alway have a reading of 1000 (also when sensor is not connected)

    In config.g i have the following parameters set up:
    ; Endstops
    M574 X1 Y2 S1 ; Set active high end stops & Y endstop is at high(max) position.
    M574 Z1 S2 ; Set endstops controlled by probe

    ; Z-Probe
    M558 P1 H5 F200 T9000 I0 R0.5 ; Set Z probe type mini ir sensor
    G31 P500 X-2 Y-16.4 Z1.043 ; Set Z probe trigger value, offset and trigger height
    M557 X30:270 Y30:270 S80 ; Define mesh grid

    How can I solve this problem?
    Are there things that i can measure / test to find the reason the sensor starts in digital mode instead of analogue mode?

    When I measure the voltage output of Z_probe In on the mainboard I get ~3V.
    Is this normal? I immediately get this reading when powered from USB. (did not check with PS ON)

    IMG_20191227_185202.jpg IMG_20191227_185234.jpg



  • In regard to my previous post:

    I did an extra test & disconnected the blue wire (signal In / Out)
    With only Vcc & GND connected the mini IR Probe LED blinks 4 times.

    My conclusion from this test is that the board does not correctly initialise the Probe.
    Is this a correct conclusion?
    Could this be because of the enstop configuration ("M574")?
    I have a Duet Maestro mainboard with the latest firmware: 3.0RC1 (2019-12-16b8)

    Ref: https://duet3d.dozuki.com/Wiki/Gcode#Section_M574_Set_endstop_configuration
    M574 - RepRapFirmware 3 Parameters

    Xnnn Position of X endstop: 0 = none, 1 = low end, 2 = high end.
    Ynnn Position of Y endstop: 0 = none, 1 = low end, 2 = high end.
    Znnn Position of Z endstop: 0 = none, 1 = low end, 2 = high end.
    P"pin_name" Defines the pin name(s) that the endstop(s) for the specified axis are connected to. Needed when S=1.
    Snnn 1 = switch-type (eg microswitch) endstop input, 2 = Z probe (when used to home an axis other than Z), 3 = single motor load detection, 4 = multiple motor load detection (see Notes).
    ==> What to do if you want to use a Z probe for the Z-Axis

    Example:
    M574 Z1 S1 P"zstop" ; Z min active high endstop switch
    ==> no need to refer to the pin_name for the Z Probe_In?

    I would greatly appreciate if someone could help me with initialising the mini IR Probe in the config.g file for the Maestro board (firmware 3.0RC1)



  • @schoenbekooievaar said in Mini IR Probe configure issue:

    I have a Duet Maestro mainboard with the latest firmware: 3.0RC1 (2019-12-16b8)
    M558 P1 H5 F200 T9000 I0 R0.5 ; Set Z probe type mini ir sensor

    that config line is not for rrf3 but for rrf2

    i suggest you generate a new config while selecting rrf3 in the configurator


  • administrators

    Did this work using RRF 2 previously?

    Its been ages since I used an IR probe but working through it:

    1. From what you said, you are setting this up as an Analog Z probe. starting with the assumption that you do not have another Z endstop connected then i think M574 should be:
    M574 Z1 S0
    
    1. You should be using M558 to setip the Z probe, something like:
    M558 P1 C"zprobe.in" H5 F120 T6000             ; set Z probe type to unmodulated and the dive height +
    speeds
    G31 P500 X2 Y10 Z2.5                            ; set Z probe trigger value, offset of 2 in X and 10 in Y and trigger height
    

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe



  • it seems he is missing the entire io mapping. that is why i suggested to recreate the config.

    but if you want to adapt the config. you need to add io mapping for each endstop
    like
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop

    the probe like tony said

    heater like
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1

    and fans like
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on



  • @T3P3Tony

    Worked perfectly, Thank you!!!



  • @Veti

    Thank you for the tip!!! Will do this in the future to try and solve it myself.
    I started from the BLV-Cube pre configured files.

    For some reason the x & y endstop work without the suggested modification.
    (will modify and test this anyway)

    Also thank you for pointing out to the heater & fan setting.
    Those are the next things I need to find out if it works as intended.


Log in to reply