RRF Config Tool Bug



  • Hi

    I've been trying to setup three thermocouples over the last days using two temp daughterboards. Up until now, I was only able to get a reading from the first two sensors. Today, I tried the RRF v3 on my Duet 2 Wifi.

    I used the RRF Config Tool to create a fresh set of files. Then, I tried them and I got even less response from the sensors. Suddenly, all of them seemed to be dead. After looking up the new M308 syntax https://duet3d.dozuki.com/Wiki/RepRapFirmware_3_overview#Section_M308_Create_or_modify_sensor_or_report_sensor_parameters and referencing that to the generated config files I realized that there is a bug in the config tool.

    This is the command it should be: M308 S1 P"spi.cs1" Y"thermocouple-max31855"
    And instead the online tool gives you this: M308 S1 P"spi.cs1" Y"max31855"

    Please fix this.

    Other than that, my struggle is still far from over. Now there is still a real fault in the thermocouple... The sheath it shorted to the signals 😰


  • administrators

    thanks for reporting this. hopefully @chrishamm will get chance to fix it shortly.


Log in to reply