Z axis on corexy always has a offset even after homing.



  • Its been a years since i've had the printer running, just got it going again today. It had this issue when I took a break from it.
    The printer is custom built core xy running duet fw 2.0 and dwc 1.21.1

    I looked through all the settings over and over, couldn't find anything out of the ordinary.
    So when i home all with G28 from dwc it all does exactly as its expected to goes through homing x and y with sensorless homing, then jogging the head over to the front right corner to home z near the z adjust screw.
    after its all done. Dwc reads X320Y0Z4.15 Its saying z is 4.15mm above the bed while its physically touching the build plate.homeall.g config-override.g config.g bed.g

    Any help would be greatly appreciated



  • You Z-Probe section in config.g is completely commented out.



  • That's true, it is commented out because i used to have a piezo installed. I don't have it on the printer anymore so I'm just using a end stop right now.



  • Sorry overlooked "sensorless homing"



  • I noticed that I was missing M574 Z1 S1 That could be my issue, ill give it a go tomorrow. Kinda doubt that's that problem, but it's something.


  • Moderator

    G1 X-400 F4000 S1 ; move X all the way left and stop at end
    G1 X9 ; move to edge of glass
    G92 X0 ; set X0 at edge of glass
    G1 Y-400 F4000 S1 ; move Y all the way left and stop at end
    G1 Y30 ; move to edge of glass
    G92 Y0 ; set Y0 at edge of glass

    Using G92 to reset the position in the homing files is a little risky, since if the initial homing pass fails or triggers falsely, it will set an incorrect position.

    You can achieve the same effect by setting a negative minima value for M208 X and Y such that the 0 position is at the edge of the build plate.

    Oh wait...

    ; Axis Limits
    M208 X-8 Y-30 Z0 S1 ; Set axis minima
    M208 X335 Y320 Z750 S0 ; Set axis maxima

    You're already doing that. But now you're doing it twice?

    @Jbourns said in Z axis on corexy always has a offset even after homing.:

    I was missing M574 Z1 S1

    Yes you'll need that this may be why the position isn't updating when triggering the endstop.

    @Jbourns said in Z axis on corexy always has a offset even after homing.:

    running duet fw 2.0 and dwc 1.21.1

    Might be a good time to update to 2.05 to get caught up with things.



  • What would you suggest as a safer way of setting x and y?

    what am i doing twice? i dont see what you mean.
    I'll update it once this little problem is fixed.


  • Moderator

    When the endstop is hit the axis position is set to either the maxima or minima value as configured in m208. In your m208 you have a negative value which indicates the endstop is that far away from the bed corner. But then your homing script moves the axis back a few mm and resets the position. If the m208 values are right, you don't need the g92 in the homing script.

    There may not be any actual issue from this as long as the nozzle is staying on the bed, but the actual position values may be shifted of you see what I mean.



  • I think the G92 is a hangover from the original versions or reprap firmware. Pre dc42. I certinally remember them from my Ormerod's default files.

    Essentially when you command a drive to limit switch the firmware will set the minimum or maximum value of M208 as the current position when the switch ia triggered.

    ...as above! 😉

    I blame it on hoing cold turkey on caffeine a week or so ago! 😄


Log in to reply