Heater Fault problems



  • Been having trouble with heater faults on my bed lately and not sure what steps to take next. Temp vs Time map is erratic when heating but seems to stabilize at around 90c (if it gets there before faulting). I have checked the wiring, re-crimped the terminals, and checked their connections and this hasn't done a thing.

    The terminals on my Duet seem to be a little loose however I am not sure that is the issue given that the erratic temps go away after it reaches temp.

    I have a Keenovo silicone heater and the thermister is built into the heater so not sure how I would replace it short of drilling a hole in the aluminum build plate and putting a new one there.

    I have access to the bottom of the heat bed while it is heating and using a piece of metal to "massage" the area where the thermister is (checking for a loose connection) does not change the erratic behavior.

    Any suggestions of what to try next would be appreciated.



  • @p40whk said in Heater Fault problems:

    The terminals on my Duet seem to be a little loose

    What exactly do you mean by this?



  • @Phaedrux said in Heater Fault problems:

    @p40whk said in Heater Fault problems:

    The terminals on my Duet seem to be a little loose

    What exactly do you mean by this?

    Well, you can wiggle them with your finger as if the solder joints aren't solid.

    However, I think I have found the issue. I took a Multimeter to the terminals as it was heating and got a consistent voltage so I ruled that out. Happened to have a spare thermistor for a hotend and clamped that to the bed to see if that was the iss. That was it. no issues with heater faults and the graph on the temp panel is smooth as silk.


Log in to reply