BL TOUCH CONFIGURATION



  • HI ,
    i'm new with my DUET 2 wifi V1.04 and try to confirgure my Alfawise U20 with it.

    i'm running:
    Duet 2 wifi 1.04
    3.0 firmware
    new BL Touch

    i've follow all the tutorials to configure the BL touch, but still nothing , and i've try many things, my BL touch is plug into:
    z probe in/ GND for Z probe
    +5v/GND and Pin8 HEATER3 for the servos cable

    i've try many change on the file config.g but nothing seems to work and the command S10, S120 result on a bad command in the DWC.

    here my config.g:

    ; Endstops
    M574 X1 S0 P"xstop" ; configure active-low endstop for low end on X via pin xstop
    M574 Y1 S0 P"ystop" ; configure active-low endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M950 S0 C"exp.heater3" ; create servo pin 0 for BLTouch
    M558 P9 C"zprobe.in" H3 F120 T4800 ; set Z probe type to bltouch and the dive height + speeds
    M558 H30 ;*** Remove this line after delta calibration has been done and new delta
    parameters have been saved
    G31 P25 X-35 Y10 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:285 Y15:285 S20 ; define mesh grid

    ; Heaters
    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4700 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S70 ; set temperature limit for heater 0 to 70C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit
    M308 S1 P"e0temp" Y"thermistor" T100000 B4700 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S230 ; set temperature limit for heater 1 to 230C
    M307 H1 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit

    my deployprobe.g:
    M280 P0 S10 I1 ; deploy BLTouch
    my retractprobe.g:
    M280 P0 S90 I1 ; retract BLTouch

    did you have some idea of what happen? how to solve.
    thanks
    christophe



  • @christophe31 said in BL TOUCH CONFIGURATION:

    M558 P9 C"zprobe.in"

    You have to invert the input



  • Also remove the I commands from deployprobe.g and retractprobe.g



  • @christophe31
    Please also check the homez.g and the homeall.g. if the G30 is included.
    Otherwise the probe will not be deployed and retracted in the homing moves.



  • @DIY-O-Sphere said in BL TOUCH CONFIGURATION:

    @christophe31 said in BL TOUCH CONFIGURATION:

    M558 P9 C"zprobe.in"

    You have to invert the input

    when i delete the " ^ "it's the same issue will look at the other files you say and come back



  • here my homeall.g:
    G91 ; relative positioning
    G1 H2 Z5 F4800 ; lift Z relative to current position
    G1 H1 X-305 Y-305 F6000 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F4800 ; go back a few mm
    G1 H1 X-305 Y-305 F600 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X50 Y5 F4800 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F80 ; lift Z relative to current position
    ;G90 ; absolute positioning

    and my homez.g:
    G91 ; relative positioning
    G1 H2 Z5 F4800 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X50 Y5 F4800 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F80 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @christophe31 said in BL TOUCH CONFIGURATION:

    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch

    Witch RRF3 version are you using.?
    For the stable you have to remove this



  • @DIY-O-Sphere said in BL TOUCH CONFIGURATION:

    @christophe31 said in BL TOUCH CONFIGURATION:

    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch

    Wtch RRF3 version are you using.?
    For the stable you can remove this

    yes i've remove this line

    allelluia my Z homing fonctionning... THANKS A LOT one who know here better than 100 who search..
    the only issue i have is that the homing for the Z is not in the center of my bed, did you know the line to correct?



  • @christophe31 said in BL TOUCH CONFIGURATION:

    G1 X50 Y5 F4800 ; go to first probe point

    Adept those lines in both homing files



  • @DIY-O-Sphere said in BL TOUCH CONFIGURATION:

    @christophe31 said in BL TOUCH CONFIGURATION:

    G1 X50 Y5 F4800 ; go to first probe point

    Adept those lines in both homing files

    yes found everything seems to work fine, thanks a lot again, for your fat answer.
    i'm too happy lol:)



  • @christophe31 said in BL TOUCH CONFIGURATION:

    i'm too happy lol:)

    You are wellcome


Log in to reply