After Firmware update on Duet 2 Ethernet from 2.04 to 3 Error



  • Hello
    After update on Duet2 Ethernet i have a Problem when i heating the Bed.
    It show me an error: Heating fault on heater 0 temperature rising more slowly than the expected 0.8°C/sec.

    here my config:
    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.7 on Wed Jan 15 2020 14:35:10 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Deltawasp 2.0" ; set printer name
    M665 R175 L295 B110 H416 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X256 Y256 Z256 E64 I0 ; configure microstepping without interpolation
    M92 X1350.00 Y1350.00 Z1350.00 E663.00 ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1600.00 ; set accelerations (mm/s^2)
    M906 X1600 Y1600 Z1600 E1000 ; set motor currents (mA)
    M84 S0 ; Disable motor idle current reduction

    ; Axis Limits
    M208 Z0 S1 ; set minimum Z

    ; Endstops
    M574 X2 S1 P"xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"ystop" ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S1 P"zstop" ; configure active-high endstop for high end on Z via pin zstop

    ; Z-Probe
    M558 P0 H0 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 R85 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S300 ; set temperature limit for heater 1 to 300C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S1 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H-1 ; set fan 1 value. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F-1 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • Have you re PID tuned it?

    M303 H0 S70
    

    for example



  • No, i will do it now. Thanks, i will reply after



  • @jay_s_uk Thanks, it works. i'm stupid xD


  • administrators

    @goodchrhere said in After Firmware update on Duet 2 Ethernet from 2.04 to 3 Error:

    @jay_s_uk Thanks, it works. i'm stupid xD

    No you're not, it's something I overlooked. In RRF2 the bed heater used to default to bang-bang and a different heater model from the extruder. But RRF3 doesn't know how you will use a heater when you create it, so the default heater parameters are OK for some extruders but don't suit most beds. This means you might get away with not tuning the bed heater in RRF2, but you probably won't with RRF3.



  • okay i understand, it work by the 3d printer in the company. At home i have the same problem. I tuned the bed, and it will be heat up. but when i set 50° for bed, it will heat. After to reach 50° the voltage from 12V goes down to 9.5V. I have a 12V bed with a ssr.
    The heatbed https://www.3dware.ch/MK3-Alu-Heizbett-400mm-x-300mm-De.htm
    The ssr: https://www.aliexpress.com/item/32756137315.html?spm=a2g0s.9042311.0.0.27424c4dRuqXvc

    In rrf2 it works fine and in rrf3 it give an error.



  • Has my bed malfunction, or my ssr?
    Or have i a false phrase in rrf3?



  • @goodchrhere said in After Firmware update on Duet 2 Ethernet from 2.04 to 3 Error:

    After to reach 50° the voltage from 12V goes down to 9.5V.

    This indicates an underlying hardware problem. It may not have been as obvious in RRF2, but it was there.


Log in to reply