Delta with offset probe. Issues leveling.



  • Hi,

    I have a 200mm diameter delta running a duet 2. It has a microswitch probe on the front left of the nozzle. I have measured the probe to be 25mm to the left and 12.5mm in front of the nozzle. That should equate to -X25 and -Y12.5 in the G31 entry in config.g.

    I used the RRF online config tool to make a bed.g file with those offsets. But this is also where my problems start. The left 1/4 of the bed is not probed at all. And when I try to run mesh bed leveling the same happens. There is a 25mm area outside the probe that does not got probed no mather how big I set the radius.

    I have checked that the coordinates are correct by placing an object at one probe point during mesh leveling, and then checked that the nozzle jumps over this when manually moving the head through the web interface with mesh enabled.

    My question is. Can I set the offset to 0 and then apply -X25 and -Y12.5 coordinates to the height map? I know that this also might create issues with G28.

    The reason I'm trying to resolve this is because the glass bed is slightly warped in one corner. And it is proprietary to the printer.

    I'll attach any files you request.

    Thanks!



  • Just as a shot in the dark... something to try...

    Have you tried it with the minus signs removed? I agree with your reasoning as to why they are there. Nonetheless, the first thing I always do when debugging is assume I'm "seeing offsets backwards in my head" and just a quick try of the opposite.

    And, yes, please post config.g and bed.g



  • @Danal said in Delta with offset probe. Issues leveling.:

    Just as a shot in the dark... something to try...

    Have you tried it with the minus signs removed? I agree with your reasoning as to why they are there. Nonetheless, the first thing I always do when debugging is assume I'm "seeing offsets backwards in my head" and just a quick try of the opposite.

    And, yes, please post config.g and bed.g

    Yeah, I tried with the minus signs removed. That just makes the carriage crash with a tower and then the bed.

    I verified the offset by placing a magnet at the bed right under the probe point while doing mesh. The nozzle then jumped over it while moving the head around.

    Attached are the config and bed files. I attached the config override that is created after the first G32.

    Also a picture to show the farthest left probing point.

    duet.jpg

    config.g config-override.g bed.g



  • Can I just make my own points to use instead, or does it have to be specific point created by the RRF online tool?



  • ; Configuration file for Duet WiFi (firmware version 1.21)

    are you really on that old version? if so please update to 2.05.

    M350 X64 Y64 Z64 E64:64 I1 ; Configure microstepping with interpolation

    Interpolation does only work at 16 steps. unless there is a very specific reason you should run at x16 with interpolation.

    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0

    B4138 is wrong. please replace by the correct value for your thermistor.

    Try 8 factor calibration for your delta calibration.



  • @Veti said in Delta with offset probe. Issues leveling.:

    ; Configuration file for Duet WiFi (firmware version 1.21)

    are you really on that old version? if so please update to 2.05.

    M350 X64 Y64 Z64 E64:64 I1 ; Configure microstepping with interpolation

    Interpolation does only work at 16 steps. unless there is a very specific reason you should run at x16 with interpolation.

    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0

    B4138 is wrong. please replace by the correct value for your thermistor.

    Try 8 factor calibration for your delta calibration.

    I'm on 2.05. Since mid-December.

    I use a PT100 so the thermistor settings is disregarded.

    I've tried 8 factor. It does not help the problem with the 1/4 of the bed not getting probed.

    I managed to get mesh leveling to probe the whole bed by setting a much bigger probing radius than the printer has. At r120 it probed the whole bed.



  • @Teejay187 said in Delta with offset probe. Issues leveling.:

    I use a PT100 so the thermistor settings is disregarded.

    for your bed?



  • @Veti My bad. My bed uses the correct values.

    Still need help with what I asked for in my first post...



  • So I've been reading around some more, but I got a few new questions:

    Can I create my own probing points in the bed.g file? Or does it need to be set up very specific to get the calibration factors working?

    Are there any other bed calculators that makes the correct probing points I could possible use instead? The RRF configurator is currently broken.

    Should I maybe go straight to RRF3?

    Thanks 🙂




Log in to reply