first layer height



  • Hello,

    I feel like my first layer is being smashed as it is wider that subsequent layers. I'm running version 3 of the firmware. I have the homeall file set to tell the firmware it is at z=.1. My general printing layer height is .2mm. Here is the code. Do I have it setup correctly?

    G91 ; relative positioning
    G1 H2 Z5 F12000 ; lift Z relative to current position
    G1 H1 X-205 Y-205 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F12000 ; go back a few mm
    G1 H1 X-205 Y-205 F600 ; move slowly to X and Y axis endstops once more (second pass)
    G1 H1 Z-305 F600 ; move Z down stopping at the endstop
    G1 Z3 F600 ; go back a few mm
    G1 H1 Z-305 F120 ; move slowly to Z axis endstop once more (second pass)
    G90 ; absolute positioning
    G92 Z.1 ; set Z position to axis minimum (you may want to adjust this)
    G91 ; relative positioning
    G1 Z-305 F120 ; move slowly to Z axis endstop once more (second pass)
    G90 ; absolute positioning
    G1 X0 Y0 F6000 ; go to first bed probe point



  • @mlaustin6 said in first layer height:

    G92 Z.1

    Are you sure that you are 0.1mm away from the bed when homed?

    What is your first layer height?

    Is the bed leveled?

    Have you considered getting a Z probe?



  • I am sure. I have a Prusa i3 steel, and I leveled the bed with one of those .1mm flat steel tools. My first layer height is .2mm. It makes no sense for a z probe for me as the machine is older, and it never really needs leveling once set.



  • Just as a wild test, try changing G92 Z.1 to G92 Z0.1.


  • administrators

    You set the Z coordinate before the second homing move. Put your G92 Z.1 code at the end of the file. Also, you may want to remove the last G1 X0 Y0 code or at least put a G1 Z3 before it.



  • @chrishamm said in first layer height:

    You set the Z coordinate before the second homing move. Put your G92 Z.1 code at the end of the file.

    That last long z move doesn't have a H1 so it's not homing anything.


  • administrators

    @Phaedrux said in first layer height:

    @chrishamm said in first layer height:

    You set the Z coordinate before the second homing move. Put your G92 Z.1 code at the end of the file.

    That last long z move doesn't have a H1 so it's not homing anything.

    Ah yes, I only read the "second pass" comment. But it explains why the nozzle goes to Z=0 provided it is the minimum as defined in config.g.



  • @chrishamm said in first layer height:

    You set the Z coordinate before the second homing move. Put your G92 Z.1 code at the end of the file. Also, you may want to remove the last G1 X0 Y0 code or at least put a G1 Z3 before it.

    I put G92 Z0.1 at the end. I added the zero. Why remove G1 X0 Y0? I want homing to go there. What does G1 Z3 do? Would that be so it doesn't crash into the board?



  • @Phaedrux said in first layer height:

    @chrishamm said in first layer height:

    You set the Z coordinate before the second homing move. Put your G92 Z.1 code at the end of the file.

    That last long z move doesn't have a H1 so it's not homing anything.

    I added that. Strange the RRF 3.0 generator did not include that while the older generator did.


  • administrators

    I just tried to generate the homeall.g with three switches and it appears to generate the H1 parameter for my setup. How does this homeall.g work for you?

    G91 ; relative positioning
    G1 H2 Z5 F12000 ; lift Z relative to current position
    G1 H1 X-205 Y-205 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F12000 ; go back a few mm
    G1 H1 X-205 Y-205 F600 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X0 Y0 F6000 ; go to first bed probe point
    G91 ; relative positioning
    G1 H1 Z-305 F600 ; move Z down stopping at the endstop
    G1 Z3 F600 ; go back a few mm
    G1 H1 Z-305 F120 ; move slowly to Z axis endstop once more (second pass)
    G90 ; absolute positioning
    G92 Z0.1 ; set Z position to axis minimum
    G1 Z3 F12000 ; lift the head again
    

    This will home X+Y first, then go to X=0 Y=0, and then home Z.



  • I think Z0.1 did the trick rather than Z.1. Thank you.


Log in to reply