G1 command not working



  • I can move a the axis with machine control tab correctly but the printer don't respond to G! command
    If I write in console G1 X150 Y150 nothing happen
    Any idea?



  • Not sure.

    Are those valid co-ords for your machine?

    Did you try adding a F parameter to use a known speed?

    Frederick



  • Thank you for your replay.
    Yes the coordinates are valid ( my bed is 300x300)
    I tryed to add F parameter and it works.
    But I can't understand why , shouldn't it work even without F values?



  • Hi,

    The F setting seems to be "sticky" - once set it stays set until something changes it.

    Try executing a movement command with a given F parameter.

    Now execute another movement command, with no F parameter, and you should be able to see that the speed is the same.

    Then execute a movement command with a different F parameter - different enough that the speed change is easily discernible.

    Now execute another movement command, again with no F parameter, and you should be able to see that the speed is the again new speed.

    At least that is how it appears to work for me.

    The Machine Control "jog" buttons appear to set the speed but what determines the value used I am not sure - something in the config.g file I would assume.

    Frederick
    .


  • administrators

    There is more of a discussion on how feedrate works here:

    https://duet3d.com/wiki/G-code#G0_.26_G1:_Move

    The F parameter can be set on its own line or on the same line as other variables (such a new locations to move to). Once set it is set until it is changed.



  • Thank you very much for your answer, so pratically speaking should I add a "sefoult" feedrate in config for use the G1 command without the need to declaring it?


  • administrators

    Hi Claustro, It is not normal to do that, although i don't see why it would be a problem. Slicers normally add the feed rate in at the right point so there is no need to define it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.