Bed Not heating



  • I have a brand new Duet 2 Ethernet, I can not get the heated bed to heat, I have read in other posts that M140 should confirrm it..

    Before I ring them, I just want to have some one else double check it

    I run the M140 and get

    Bed heater 0 (slot 0) is currently at 25.7°C

    The LED never lights up and I have 24V on both terminals of the bed compared to GND so the bed is not open circuit.

    if I take the BeD- lead out of the connect block and connect it to GND the bed heats up, so the bed is good and he thermistor reflects the emperature rise.

    Any thing else worth a try?

    in anticipation

    Michael


  • Moderator

    @DeadNewbie please post your config.g file, and a picture of your bed wiring. M140 on its own will just show the status of the bed, you need to set the temperature you want, eg M140 S60. See https://duet3d.dozuki.com/Wiki/Gcode#Section_M140_Set_Bed_Temperature_Fast

    You can also set the temperature in the Duet Web Control (DWC).

    Also see the extensive documentation here: https://duet3d.dozuki.com/

    Specifically about heaters: https://duet3d.dozuki.com/Wiki/Choosing_a_bed_heater#Section_Duet_2_WiFi_and_Ethernet

    Ian



  • Thanks for your help

    I knew abut m140 s60, but I was doing this via the DWC and it had 55 deg as the active temp, but some how my browser and the Duet was out of sync.

    I came back it to this morning all was the same as last night, I ran the M140 S60 and the heater came on.

    I have not been able to recreate it, but I was rebooting and changing configs so much yesterday I can only put it down to that and the way the browser cached the page.

    Off to get the BLtouch working now.

    Thanks again for getting me to do things on the command line.

    Regards

    Michael


  • Moderator

    @DeadNewbie You may have set an active temperature in DWC, but the bed heater may not have activated. It usually activates as soon as you set an Active temperature, either by selecting from the drop down list or typing in a value. You can see if the Heater is active, in standby or off by looking under the Heater name, eg in image below, Heater 1 is active (though no temperature set) Heater 0 is off. Clicking on the Heater name should cycle through the three options, too.

    47d9cd1d-e4ba-4089-9ffa-4202c215e3b4-image.png

    Ian


Log in to reply