Updating issues with both DWC and RRF



  • I bought a Duet2 Ethernet board about a year and a half ago, mounted it to my then broken printer and tried to fix it. Got the board running but niced afterwards that my X axis was hopelessly bent. Skip forward to 2 weeks ago when I finally received a new machine.

    So i hooked up my old Duet board and set it up for the new printer.

    After I got everything working I decided to do some updates.

    At that point i was running DWC 1.19 and RepRapFirmware for Duet 2 WiFi/Ethernet 2.03beta3 (2019-03-25b6)

    After finding the files for DWC 2.0.6 I pasted these into the /www Folder on my SD-Card and I got a new DWC Interface. However, when I go to the "General" Tab under Settings, I am being told that I am running DWC 2.0.4 - Strange...

    Anyways, happy with the new interface I decided to then update to RRF 3.0

    Got the files from gitHub, uploaded it trough the "Upload System Files" Option in DWC and confirmed the installation of the new firmware.

    I immediately got an M997 S0 Error: M997: In-application programming binary "iap4e.bin" not found

    So I got googling and found out that I need to download the file from this link : https://github.com/dc42/DuetIAP/blob/master/Release/iap4e.bin

    After that I tried again installing the firmware, and this time I got no error. However, DWC still shows that I am running on RepRapFirmware for Duet 2 WiFi/Ethernet 2.03beta3 (2019-03-25b6), and my config.g still works.

    What did I do wrong/did I miss? Is it possible that I need to do some sort of intermittend update to get this to work? And why was iap4e missing when I was already running 2.03? After all that I've read this issue should only be faced when updating from 1.19 or previous, no?

    Any help here would be greatly appreciated as I am kind of lost



  • Any specific reason you are going to 3 at this time? Personally, given the history/description, I'd go to the latest full release of 2.



  • I'd second, DON'T GO TO v3, as personally I don't think it's ready for mere mortals, and the changes to DWC make it unusable, for those that wear glasses, use small scree laptops etc (is there any usability testing ??).



  • @Danal I need the intermittend 3.0 update to get to 3.01beta, I have multiple Tools I can attach to my carriage, not all meant for 3D-Printing- Conditional GCode would go a long way in saving me some setup time between operations. I'll probably wait for 3.01RC2 or so, but at least I want to start adapting my configs to the new conventions.

    It does seem as though I was simply missing some intermittend updates, I've reverted to my initial backup of the SD-card and progressively installed the separate updates up to 2.05, reinstalled DWC trough the "upload system files" and then it magically worked.


  • Moderator

    Nothing wrong with jumping straight into RRF3, since you haven't used RRF2 a lot you won't have much to relearn. However it will likely be easiest if you start with a full working RRF2 implementation so that you know everything is working as it should. Then you also have something to revert to if need be when implementing RRF3.


Log in to reply